summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Letan2023-12-30 12:15:01 +0100
committerThomas Letan2023-12-30 12:36:15 +0100
commit45ba1ec0a21c2abc621d62dae9ff53bd6cf04f57 (patch)
treec3225b1db33b45ef33966b5e8c8f32ee01ea8663
parenta198a9c9c66f466e85cff17d0d9f2f3b3b425b1c (diff)
downloadaur-45ba1ec0a21c2abc621d62dae9ff53bd6cf04f57.tar.gz
Use a temporary root for Opam
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f857c18edaa..5e4b2e5adc8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spatial-shell
pkgdesc = Implementing a spatial model inspired by Material Shell, for i3 and sway.
pkgver = 6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/lthms/spatial-shell
arch = x86_64
license = MPL2
diff --git a/PKGBUILD b/PKGBUILD
index d4d10121e825..72dc9964508b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spatial-shell
pkgver=6
-pkgrel=2
+pkgrel=3
pkgdesc='Implementing a spatial model inspired by Material Shell, for i3 and sway.'
url=https://github.com/lthms/spatial-shell
license=('MPL2')
@@ -24,14 +24,19 @@ sha512sums=(
)
prepare() {
- [ -f "${HOME}/.opam/config" ] || opam init -n
+ export OPAMROOT="${srcdir}/opam"
+ rm -rf "${OPAMROOT}"
+ opam init -n
}
build() {
+ export OPAMROOT="${srcdir}/opam"
+ eval $(opam env)
cd "${srcdir}/${pkgname}-${pkgver}"
make build-deps
eval $(opam env)
make
+ rm -rf "${OPAMROOT}"
}
package() {