summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo2015-08-09 14:51:30 +0200
committerDanilo2015-08-09 14:51:30 +0200
commitcf7f076951c8d56b3f38034a68cf8f87df60ac62 (patch)
treeeedf60e00b5a1ac21ef215b9d11fc865c4e7e1e3
downloadaur-cf7f076951c8d56b3f38034a68cf8f87df60ac62.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD36
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afda3d431cc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = spatialindex
+ pkgdesc = An extensible framework that supports robust spatial indexing methods and sophisticated spatial queries.
+ pkgver = 1.8.4
+ pkgrel = 1
+ url = http://libspatialindex.github.com/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ provides = spatialindex
+ conflicts = libspatialindex-git
+ source = http://download.osgeo.org/libspatialindex/spatialindex-src-1.8.4.tar.gz
+ source = LICENSE
+ md5sums = b17f86d9a49f284fe403c19b36fb5d89
+ md5sums = 6a9a7d8158edbf1529ca46aae5a76752
+
+pkgname = spatialindex
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..888f4e789ee5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Permission is hereby granted, free of charge, to any person obtaining acopy of this software and associated documentation files (the "Software"),to deal in the Software without restriction, including without limitationthe rights to use, copy, modify, merge, publish, distribute, sublicense,and/or sell copies of the Software, and to permit persons to whom theSoftware is furnished to do so, subject to the following conditions:The above copyright notice and this permission notice shall be included inall copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c7f3e7642c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Original Maintainer: Lantald <lantald at Gmx dot com>
+# Maintainer: Danilo <aur at dbrgn dot ch>
+
+pkgname=spatialindex
+pkgver=1.8.4
+pkgrel=1
+pkgdesc='An extensible framework that supports robust spatial indexing methods and sophisticated spatial queries.'
+arch=('i686' 'x86_64')
+url="http://libspatialindex.github.com/"
+license=('MIT')
+depends=(gcc-libs)
+provides=(spatialindex)
+conflicts=(libspatialindex-git)
+source=("http://download.osgeo.org/libspatialindex/$pkgname-src-$pkgver.tar.gz"
+ 'LICENSE')
+md5sums=('b17f86d9a49f284fe403c19b36fb5d89'
+ '6a9a7d8158edbf1529ca46aae5a76752')
+
+build() {
+ cd "$srcdir/$pkgname-src-$pkgver/"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-src-$pkgver/"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-src-$pkgver/"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: