summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2019-10-11 17:14:47 -0500
committerSamuel Mesa2019-10-11 17:14:47 -0500
commita65ae71d44f81c5865d5fc0b329f8e7a851fe854 (patch)
tree8bd6b037cdfd652f1a5f99825be966c9dff73012
parente8f0bf4a222563e3637889772bf145880a278d2e (diff)
downloadaur-spatialite-gui-devel.tar.gz
Update version to FOSSIL
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b994d087b976..fac4310b2682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spatialite-gui-devel
pkgdesc = spatialite-gui is an open source Graphical User Interface (GUI) tool supporting SpatiaLite. Development version
- pkgver = 2.1.0
+ pkgver = r230.0942f54
pkgrel = 1
url = https://www.gaia-gis.it/fossil/spatialite_gui/index
arch = x86_64
@@ -8,14 +8,13 @@ pkgbase = spatialite-gui-devel
license = GPLv3
depends = libspatialite-devel
depends = librasterlite2-devel
- depends = virtualpg2-devel
+ depends = virtualpg-devel
depends = wxgtk
depends = openjpeg2
depends = libiconv
+ provides = spatialite-gui
conflicts = spatialite-gui
replaces = spatialite-gui
- source = http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-2.1.0-beta0.tar.gz
- md5sums = f06289fa547e596d9c01c23c5e1722ec
pkgname = spatialite-gui-devel
diff --git a/PKGBUILD b/PKGBUILD
index e291d270bce3..d811cfde744a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,47 @@
# Contributor: snork
pkgname=spatialite-gui-devel
-pkgver=2.1.0
-_pkgver=2.1.0-beta0
+_pkgname=spatialite-gui
+pkgver=r230.0942f54
pkgrel=1
pkgdesc="spatialite-gui is an open source Graphical User Interface (GUI)
tool supporting SpatiaLite. Development version"
url="https://www.gaia-gis.it/fossil/spatialite_gui/index"
arch=('x86_64' 'i686')
license=('GPLv3')
-depends=('libspatialite-devel' 'librasterlite2-devel' 'virtualpg2-devel' 'wxgtk' 'openjpeg2' 'libiconv')
-conflicts=(spatialite-gui)
-replaces=(spatialite-gui)
-source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${_pkgver}.tar.gz")
-_pkgname=spatialite_gui
+depends=('libspatialite-devel' 'librasterlite2-devel' 'virtualpg-devel' 'wxgtk' 'openjpeg2' 'libiconv')
+conflicts=('spatialite-gui')
+provides=('spatialite-gui')
+replaces=('spatialite-gui')
-md5sums=('f06289fa547e596d9c01c23c5e1722ec')
+prepare() {
+ mkdir -p $_pkgname
+ cd $_pkgname
+
+ fossil clone https://www.gaia-gis.it/fossil/spatialite_gui spatialite_gui.fossil
+ fossil open spatialite_gui.fossil
+}
+
+pkgver() {
+ cd $_pkgname
+
+ _hash=$(fossil info | sed -n 's/checkout: *\([0-9a-z]*\).*/\1/p' | cut -c 1-7)
+ _revision=$(fossil info | sed -n 's/check-ins: *\(.*\)/\1/p')
+ printf "r%s.%s" "$_revision" "$_hash"
+}
build() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd ${_pkgname}
./configure --prefix="/usr" \
CXXFLAGS="`wx-config --version=3.0 --cxxflags`" \
LIBS="`wx-config --version=3.0 --libs`"
- make -j4
+ make
}
package() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd ${_pkgname}
make DESTDIR="${pkgdir}" install
install -D -m644 gnome_resource/spatialite-gui.desktop "${pkgdir}"/usr/share/applications/spatialite-gui.desktop
install -D -m644 gnome_resource/spatialite-gui.png "${pkgdir}"/usr/share/pixmaps/spatialite-gui.png