summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Fernando Mesa Giraldo2016-10-02 16:09:31 -0500
committerSamuel Fernando Mesa Giraldo2016-10-02 16:09:31 -0500
commitcba52b90f0f6d125029df72a5feed2eb36564c90 (patch)
tree5343c27649192804b4bb73fff38904d9f7d16e5d
downloadaur-cba52b90f0f6d125029df72a5feed2eb36564c90.tar.gz
Init source code
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0056ed5ac46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = spatialite-gui-devel
+ pkgdesc = spatialite-gui is an open source Graphical User Interface (GUI) tool supporting SpatiaLite. Development version
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://www.gaia-gis.it/fossil/spatialite_gui/index
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ depends = libspatialite>=4.1.1-3
+ depends = librasterlite2-devel
+ depends = wxgtk
+ conflicts = spatialite-gui
+ replaces = spatialite-gui
+ source = http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-2.0.0-devel.tar.gz
+ md5sums = 2ad2936e34923029b9b6cd94c428066c
+
+pkgname = spatialite-gui-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce996888fb54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Samuel Mesa <samuelmesa dot gmail.com>
+# Initial Maintainer: strigyskow
+# Contributor: snork
+
+pkgname=spatialite-gui-devel
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="spatialite-gui is an open source Graphical User Interface (GUI)
+tool supporting SpatiaLite. Development version"
+url="https://www.gaia-gis.it/fossil/spatialite_gui/index"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=('libspatialite>=4.1.1-3' 'librasterlite2-devel' 'wxgtk')
+conflicts=(spatialite-gui)
+replaces=(spatialite-gui)
+source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${pkgver}-devel.tar.gz")
+_pkgname=spatialite_gui
+
+md5sums=('2ad2936e34923029b9b6cd94c428066c')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}-devel"
+
+ ./configure --prefix="/usr" --enable-rl2extra
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}-devel"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 gnome_resource/spatialite-gui.desktop "${pkgdir}"/usr/share/applications/spatialite-gui.desktop
+ install -D -m644 gnome_resource/spatialite-gui.png "${pkgdir}"/usr/share/pixmaps/spatialite-gui.png
+}