summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2017-10-16 12:55:55 -0500
committerSamuel Mesa2017-10-16 12:55:55 -0500
commitdeb8813c6ed11e3eb9c16e0c81035f1dc62656e4 (patch)
tree3a00a66852ccf7717b67e010e9827d1ba83f5899
parentcba52b90f0f6d125029df72a5feed2eb36564c90 (diff)
downloadaur-deb8813c6ed11e3eb9c16e0c81035f1dc62656e4.tar.gz
Fix error compiling wih new GCC version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--patch01_pointer.patch11
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0056ed5ac46..3f33d1985404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spatialite-gui-devel
pkgdesc = spatialite-gui is an open source Graphical User Interface (GUI) tool supporting SpatiaLite. Development version
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.gaia-gis.it/fossil/spatialite_gui/index
arch = x86_64
arch = i686
@@ -12,7 +12,9 @@ pkgbase = spatialite-gui-devel
conflicts = spatialite-gui
replaces = spatialite-gui
source = http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-2.0.0-devel.tar.gz
+ source = patch01_pointer.patch
md5sums = 2ad2936e34923029b9b6cd94c428066c
+ md5sums = d3ae41d66f29d838089221dc793ee95e
pkgname = spatialite-gui-devel
diff --git a/PKGBUILD b/PKGBUILD
index ce996888fb54..c8213f1ba9d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=spatialite-gui-devel
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="spatialite-gui is an open source Graphical User Interface (GUI)
tool supporting SpatiaLite. Development version"
url="https://www.gaia-gis.it/fossil/spatialite_gui/index"
@@ -13,15 +13,22 @@ license=('GPLv3')
depends=('libspatialite>=4.1.1-3' 'librasterlite2-devel' 'wxgtk')
conflicts=(spatialite-gui)
replaces=(spatialite-gui)
-source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${pkgver}-devel.tar.gz")
+source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${pkgver}-devel.tar.gz"
+ patch01_pointer.patch)
_pkgname=spatialite_gui
-md5sums=('2ad2936e34923029b9b6cd94c428066c')
+md5sums=('2ad2936e34923029b9b6cd94c428066c'
+ 'd3ae41d66f29d838089221dc793ee95e')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}-devel"
+ patch -p0 < ../patch01_pointer.patch
+}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}-devel"
- ./configure --prefix="/usr" --enable-rl2extra
+ ./configure --prefix="/usr" --disable-openjpeg
make
}
diff --git a/patch01_pointer.patch b/patch01_pointer.patch
new file mode 100644
index 000000000000..943561141a75
--- /dev/null
+++ b/patch01_pointer.patch
@@ -0,0 +1,11 @@
+--- ResultSetView.cpp
++++ ResultSetView.new.cpp
+@@ -494,7 +494,7 @@
+ {
+ // strips any leading white-space
+ const char *p = dirty;
+- while (p != '\0')
++ while (*p != '\0')
+ {
+ if (*p == ' ')
+ {