summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2014-12-29 04:06:38 -0500
committerIdo Rosen2014-12-29 04:06:50 -0500
commitc79f251ade469c1082548d6ff113130d3d7bf0b1 (patch)
tree05e1919003b7b8dc31917d648ac29e2360712d56
downloadaur-c79f251ade469c1082548d6ff113130d3d7bf0b1.tar.gz
Added spdlog-git.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5197a3ab648
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = spdlog-git
+ pkgdesc = Super fast C++ logging library
+ pkgver = .545.267c9c6
+ pkgrel = 1
+ url = https://github.com/gabime/spdlog
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = spdlog
+ conflicts = spdlog
+ options = !strip
+ options = staticlibs
+ source = git+https://github.com/gabime/spdlog.git
+ md5sums = SKIP
+
+pkgname = spdlog-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..918665c5416a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id$
+# Maintainer: Ido Rosen <ido@kernel.org>
+#
+# NOTE: To request changes to this package, please submit a pull request
+# to the GitHub repository at https://github.com/ido/packages-archlinux
+# Otherwise, open a GitHub issue. Thank you! -Ido
+#
+
+pkgname=spdlog-git
+pkgver=.545.267c9c6
+pkgrel=1
+pkgdesc='Super fast C++ logging library'
+arch=('any')
+#arch=('i686' 'x86_64')
+url="https://github.com/gabime/spdlog"
+license=('MIT')
+depends=()
+makedepends=('git')
+provides=('spdlog')
+conflicts=('spdlog')
+# don't strip binaries!
+options=('!strip' 'staticlibs')
+source=("git+https://github.com/gabime/spdlog.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/spdlog"
+ printf "%s.%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd spdlog
+ mv include/spdlog/details/format{.cc,-impl.h}
+ sed -i 's/format\.cc/format-impl.h/' include/spdlog/details/format.h
+}
+
+#build() {
+#}
+
+#check() {
+#}
+
+package() {
+ cd spdlog
+ # systemd
+ install -dm755 "$pkgdir/usr/include/spdlog"
+ cp -R "include/spdlog/." "$pkgdir/usr/include/spdlog/"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/spdlog-git/README.md"
+ install -Dm644 "INSTALL" "$pkgdir/usr/share/doc/spdlog-git/README.md"
+ install -dm755 "$pkgdir/usr/share/doc/spdlog-git/example"
+ cp -R "example/." "$pkgdir/usr/share/doc/spdlog-git/example/"
+ install -dm755 "$pkgdir/usr/share/doc/spdlog-git/bench"
+ cp -R "bench/." "$pkgdir/usr/share/doc/spdlog-git/bench/"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/spdlog-git/LICENSE"
+ chmod -R a+rX "$pkgdir/"
+ chmod -R go-w "$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: