summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasile Vilvoiu2020-12-29 20:24:29 +0200
committerVasile Vilvoiu2020-12-29 20:24:29 +0200
commit1488a326bda5b62e56041886847ebc7b3a353ed1 (patch)
tree3aeabf2a3e5c315bcfef88336df7cad3348bb3f0
downloadaur-1488a326bda5b62e56041886847ebc7b3a353ed1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8378e3e0a09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = specgram-git
+ pkgdesc = Small program that computes and plots spectrograms, either in a live window or to disk, with support for stdin input.
+ pkgver = 20201229
+ pkgrel = 1
+ url = https://github.com/rimio/specgram
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ depends = sfml
+ depends = spdlog
+ depends = fftw
+ conflicts = specgram
+ source = git+https://github.com/rimio/specgram.git
+ md5sums = SKIP
+
+pkgname = specgram-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af574e664a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vasile Vilvoiu <vasi.vilvoiu@gmail.com>
+pkgname=specgram-git
+pkgver=20201229
+pkgrel=1
+pkgdesc="Small program that computes and plots spectrograms, either in a live window or to disk, with support for stdin input."
+arch=('x86_64')
+url="https://github.com/rimio/specgram"
+license=('MIT')
+depends=('sfml' 'spdlog' 'fftw')
+makedepends=('git' 'cmake' 'gcc')
+conflicts=('specgram')
+source=("git+https://github.com/rimio/specgram.git")
+md5sums=('SKIP')
+
+build() {
+ cd specgram
+ cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd specgram
+ make DESTDIR="$pkgdir/" install
+}