summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorohli2016-07-29 00:01:21 +0200
committerohli2016-07-29 00:01:21 +0200
commit72055713bee141e2d164f04d21cece5b9e48a616 (patch)
tree85245f74668b933362c1bdfaf2b851ccaf78e39c
downloadaur-72055713bee141e2d164f04d21cece5b9e48a616.tar.gz
My first PKGBUILD..
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e2c58edcf0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = specmatch
+ pkgdesc = Can be used to produce your own Impulse Responses and to adapt the sound produced by a Guitarix setting to another recorded sound.
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://sourceforge.net/projects/guitarix/files/specmatch/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = guitarix2
+ depends = jack2
+ depends = python2
+ depends = python2-matplotlib
+ depends = pygtk
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-pip
+ optdepends = qjackctl: GUI for jackd
+ source = https://sourceforge.net/projects/guitarix/files/specmatch/python-specmatch-0.9.tar.gz
+ md5sums = 032ac92fd766a4f5707075a935c35d5d
+
+pkgname = specmatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed911e3b5ed2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: ohli <olifriedrich@gmail.com>
+
+pkgname=specmatch
+pkgver=0.9
+pkgrel=1
+epoch=
+pkgdesc="Can be used to produce your own Impulse Responses and to adapt the sound produced by a Guitarix
+setting to another recorded sound."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/guitarix/files/specmatch/"
+license=('GPL')
+groups=()
+depends=('guitarix2' 'jack2' 'python2' 'python2-matplotlib' 'pygtk' 'python2-numpy' 'python2-scipy' 'python2-pip' )
+makedepends=()
+checkdepends=()
+optdepends=( 'qjackctl: GUI for jackd' )
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://sourceforge.net/projects/guitarix/files/specmatch/python-$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('032ac92fd766a4f5707075a935c35d5d')
+validpgpkeys=()
+
+prepare() {
+ pip install --install-option="--prefix=$pkgdir" scikits.audiolab
+}
+
+package () {
+ cd "$pkgname"
+ sudo python2 ./setup.py install
+}
+