summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2020-11-14 21:37:44 +0100
committerMagnus Boman2020-11-14 21:37:44 +0100
commitbcdd63fe76c3ae0550b3741e7a8a594516b782c1 (patch)
tree86fcc2b9be28ee39c1e0e509267c59053ec35503
parent15542e6bc2ac7962e3f5c123fbdc1126bc1d8e9c (diff)
downloadaur-bcdd63fe76c3ae0550b3741e7a8a594516b782c1.tar.gz
upgpkg: spectacle-git 20.08.2.r47.g89e9eed-1
add kimageannotator support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1263594033f6..001f4fc45ab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spectacle-git
pkgdesc = KDE screenshot capture utility
- pkgver = 20.07.80.r7.g7931ff8
+ pkgver = 20.08.2.r47.g89e9eed
pkgrel = 1
url = https://kde.org/applications/utilities/org.kde.spectacle
arch = i686
@@ -17,6 +17,7 @@ pkgbase = spectacle-git
depends = knewstuff
depends = kwayland
depends = qt5-tools
+ depends = kimageannotator
optdepends = kipi-plugins: export to various online services
provides = spectacle
conflicts = spectacle
@@ -24,4 +25,3 @@ pkgbase = spectacle-git
md5sums = SKIP
pkgname = spectacle-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f618bdba2da2..8f2e02c547cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=spectacle-git
-pkgver=20.07.80.r7.g7931ff8
+pkgver=20.08.2.r47.g89e9eed
pkgrel=1
pkgdesc='KDE screenshot capture utility'
arch=(i686 x86_64)
url=https://kde.org/applications/utilities/org.kde.spectacle
license=(GPL)
-depends=(xcb-util-cursor libkipi purpose knewstuff kwayland qt5-tools)
+depends=(xcb-util-cursor libkipi purpose knewstuff kwayland qt5-tools kimageannotator)
makedepends=(extra-cmake-modules kdoctools git)
optdepends=('kipi-plugins: export to various online services')
conflicts=("${pkgname%-git}")
@@ -19,16 +19,15 @@ source=(git+https://invent.kde.org/graphics/spectacle.git)
md5sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cmake -B build -S "${pkgname%-git}" \
- -DBUILD_TESTING=OFF
- cmake --build build
+ cmake -B build -S "${pkgname%-git}" \
+ -DBUILD_TESTING=OFF
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}