summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2015-10-08 01:23:19 +0200
committerAndrea Scarpino2015-10-08 01:23:19 +0200
commite5afdceca7fbe160841277446fa5f37d7503756f (patch)
tree03472b3d57472da8b45f31414e73464c65412011
downloadaur-e5afdceca7fbe160841277446fa5f37d7503756f.tar.gz
First
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--spectacle-git.install12
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5898af97b5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = spectacle-git
+ pkgdesc = The new screenshot capture utility, replaces KSnapshot
+ pkgver = r123.26ede97
+ pkgrel = 1
+ url = https://projects.kde.org/projects/spectacle
+ install = spectacle-git.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = kio
+ depends = libkscreen
+ depends = xcb-util-cursor
+ depends = libkipi-git
+ conflicts = spectacle-git
+ conflicts = kscreengenie-git
+ conflicts = kdegraphics-ksnapshot
+ replaces = kscreengenie-git
+ replaces = kdegraphics-ksnapshot
+ source = git://anongit.kde.org/spectacle.git
+ md5sums = SKIP
+
+pkgname = spectacle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e491d3745fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=spectacle-git
+pkgver=r123.26ede97
+pkgrel=1
+pkgdesc='The new screenshot capture utility, replaces KSnapshot'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/spectacle'
+license=('LGPL')
+depends=('kio' 'libkscreen' 'xcb-util-cursor' 'libkipi-git')
+makedepends=('extra-cmake-modules' 'git')
+conflicts=('spectacle-git' 'kscreengenie-git' 'kdegraphics-ksnapshot')
+replaces=('kscreengenie-git' 'kdegraphics-ksnapshot')
+install=${pkgname}.install
+source=('git://anongit.kde.org/spectacle.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd spectacle
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../spectacle \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/spectacle-git.install b/spectacle-git.install
new file mode 100644
index 000000000000..5495fb1b5d27
--- /dev/null
+++ b/spectacle-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}