summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2016-12-26 15:20:13 +0100
committerBruno Pagani2016-12-26 15:20:13 +0100
commit87f6f695c43aab064f37e1c3b895ab2f9a15307e (patch)
tree58c50cf10be0b64085a6feef32bae79c3b31f124
parent65c18e158e0d571d65bdbf0afdd9b7a09518fc02 (diff)
downloadaur-87f6f695c43aab064f37e1c3b895ab2f9a15307e.tar.gz
Fix wrong pkgbase use
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9356fece1a79..143e0255e7ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = spectacle
+pkgbase = spectacle-light
pkgdesc = KDE screenshot capture utility, without purpose
pkgver = 16.12.0
pkgrel = 1
diff --git a/PKGBUILD b/PKGBUILD
index 3f58fc7179bc..9466e712639e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
-pkgbase=spectacle
-pkgname=spectacle-light
+_pkgname=spectacle
+pkgname=${_pkgname}-light
pkgver=16.12.0
pkgrel=1
pkgdesc="KDE screenshot capture utility, without purpose"
@@ -15,7 +15,7 @@ provides=('spectacle')
conflicts=('kdegraphics-ksnapshot' 'kscreengenie' 'spectacle')
replaces=('kdegraphics-ksnapshot' 'kscreengenie')
groups=('kde-applications' 'kdegraphics')
-source=("http://download.kde.org/stable/applications/${pkgver}/src/${pkgbase}-${pkgver}.tar.xz"{,.sig})
+source=("http://download.kde.org/stable/applications/${pkgver}/src/${_pkgname}-${pkgver}.tar.xz"{,.sig})
sha256sums=('31d4b00da13c9cc68b2d8f3c4633cba8e4ba82f819d3edac87aecd4fa70f31b3' 'SKIP')
validpgpkeys=('CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7') # Albert Astals Cid <aacid@kde.org>
@@ -25,7 +25,7 @@ prepare() {
build() {
cd build
- cmake "../${pkgbase}-${pkgver}" \
+ cmake ../${_pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DKDE_INSTALL_LIBDIR=lib \
@@ -34,7 +34,7 @@ build() {
make
}
-package_spectacle-light() {
+package() {
cd build
make DESTDIR="${pkgdir}" install
}