summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitcoinlizard2022-04-05 20:50:25 -0500
committerbitcoinlizard2022-04-05 20:50:25 -0500
commitd2dd9dc3273963f1254871aa2e8a9fbd8586ab20 (patch)
treecd50de5c7e1fdde8af56d5d9e0ea1b9d397f3b56
parent0ecfb7c8688601d172a3f7185ab8560ebf1ed21b (diff)
downloadaur-d2dd9dc3273963f1254871aa2e8a9fbd8586ab20.tar.gz
improve PKGBUILD to include configuration instructions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--specter-desktop.install24
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12733f7c3dea..7eaab13465bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = specter-desktop
pkgdesc = Specter Desktop functions as a watch-only coordinator for multi-signature and single-key Bitcoin wallets.
pkgver = 1.9.2
- pkgrel = 1
+ pkgrel = 2
url = https://specter.solutions
+ install = specter-desktop.install
arch = any
license = MIT
makedepends = python-setuptools
@@ -38,8 +39,10 @@ pkgbase = specter-desktop
source = https://github.com/cryptoadvance/specter-desktop/archive/refs/tags/v1.9.2.tar.gz
source = specter.service
source = version.patch
+ source = specter-desktop.install
sha256sums = 711648c9b82ddc166ef927830fb2534fbe6bbdf4c1b2449bfd0edabf67d6e6e7
sha256sums = 9b5f57a0ebd48e6b7d1ac240913e4b502a6e3ffc5b64ff87ed263f1a4810a265
sha256sums = d073993940a460454ac8d9e7e3b4b073ad8d4826ede06c57c333899efba0d7f8
+ sha256sums = 668ace7f14369014e42197321fa7e0edc90737c87e2b6a68354ab205d37e3aa6
pkgname = specter-desktop
diff --git a/PKGBUILD b/PKGBUILD
index c8fe68d95d5c..8ee52fccff8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=specter-desktop
pkgver=1.9.2
-pkgrel=1
+pkgrel=2
pkgdesc="Specter Desktop functions as a watch-only coordinator for multi-signature and single-key Bitcoin wallets."
arch=('any')
url="https://specter.solutions"
@@ -11,13 +11,16 @@ makedepends=('python-setuptools')
depends=('python' 'libusb' 'systemd-libs' 'python-dotenv' 'python-flask' 'python-flask-login' 'python-flask-wtf' 'python-mnemonic' 'python-hwilib' 'python-embit' 'python-flask-cors' 'python-pgpy' 'python-pyopenssl' 'python-stem'
'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata' 'python-daemonize' 'python-noiseprotocol-git' 'python-wheel' 'python-pyasn1' 'python-cbor' 'python-urllib3' 'python-flask-babel' 'python-flask-apscheduler')
backup=(usr/lib/systemd/system/specter.service)
+install=$pkgname.install
source=("https://github.com/cryptoadvance/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
'specter.service'
- 'version.patch')
+ 'version.patch'
+ 'specter-desktop.install')
sha256sums=('711648c9b82ddc166ef927830fb2534fbe6bbdf4c1b2449bfd0edabf67d6e6e7'
'9b5f57a0ebd48e6b7d1ac240913e4b502a6e3ffc5b64ff87ed263f1a4810a265'
- 'd073993940a460454ac8d9e7e3b4b073ad8d4826ede06c57c333899efba0d7f8')
+ 'd073993940a460454ac8d9e7e3b4b073ad8d4826ede06c57c333899efba0d7f8'
+ '668ace7f14369014e42197321fa7e0edc90737c87e2b6a68354ab205d37e3aa6')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/specter-desktop.install b/specter-desktop.install
new file mode 100644
index 000000000000..d2f6ece567a8
--- /dev/null
+++ b/specter-desktop.install
@@ -0,0 +1,24 @@
+
+post_install() {
+
+ echo "$(tput setaf 1)To actually get Specter running you have 2 options. You can use the included Systemd $(tput sgr0)"
+ echo "$(tput setaf 1)Service file which is installed to here:$(tput sgr0)"
+ echo "$(tput setaf 1)/usr/lib/systemd/system/specter.service$(tput sgr0)"
+ echo "$(tput setaf 1)You can edit this file to suit your needs, probably adding the --cert and --key options and$(tput sgr0)"
+ echo "$(tput setaf 1)specifying the cert names. You will have to generate your own certificates. This is recommended by$(tput sgr0)"
+ echo "$(tput setaf 1)Specter and perhaps required to use a webcam for scanning QR codes. Alternatively you can run the service$(tput sgr0)"
+ echo "$(tput setaf 1)file as is without changes and you will be able to access the http interface rather than the secure $(tput sgr0)"
+ echo "$(tput setaf 1)https interface. If you simply want to run Specter from the CLI and not use the Systemd service $(tput sgr0)"
+ echo "$(tput setaf 1)you can run this command at the CLI:$(tput sgr0)"
+ echo "$(tput setaf 1)python -m cryptoadvance.specter server$(tput sgr0)"
+ echo "$(tput setaf 1)Once you have the Specter server running you will access it via your browser at:$(tput sgr0)"
+ echo "$(tput setaf 1)http://localhost:25441/ or$(tput sgr0)"
+ echo "$(tput setaf 1)https://<your domain>:25441/$(tput sgr0)"
+ echo "$(tput setaf 1)You will likely need to make an entry in /etc/hosts if you use a certificate$(tput sgr0)"
+ echo "$(tput setaf 1) $(tput sgr0)"
+
+
+}
+
+
+