summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanspeter Portner2017-06-21 15:14:11 +0200
committerHanspeter Portner2017-06-21 15:14:11 +0200
commit3ccf2f305129f5eaa77eed95a6001614b049bb49 (patch)
treefbfc5181e0b2b4b0049ed9316399f2f69dabc8e6
downloadaur-3ccf2f305129f5eaa77eed95a6001614b049bb49.tar.gz
initial import.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea9e2bba2ada
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = spectmorph
+ pkgdesc = a free software project which allows to analyze samples of musical instruments, and to combine them (morphing).
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = http://spectmorph.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = lv2-plugins
+ license = LGPL3
+ makedepends = lv2
+ depends = fftw
+ depends = qt5-base
+ depends = python
+ depends = libao
+ depends = jack
+ source = http://spectmorph.org/downloads/spectmorph-0.3.3.tar.bz2
+ md5sums = b2569267b719c619c7507f53df5c0c04
+
+pkgname = spectmorph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8282be53e9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Hanspeter Porner <dev@open-music-kontrllers.ch>
+pkgname=spectmorph
+pkgver=0.3.3
+pkgrel=1
+epoch=
+pkgdesc="a free software project which allows to analyze samples of musical instruments, and to combine them (morphing)."
+arch=(i686 x86_64 armv7h)
+url="http://spectmorph.org/"
+license=('LGPL3')
+groups=('lv2-plugins')
+depends=('fftw' 'qt5-base' 'python' 'libao' 'jack')
+makedepends=('lv2')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://spectmorph.org/downloads/$pkgname-$pkgver.tar.bz2")
+noextract=()
+md5sums=('b2569267b719c619c7507f53df5c0c04')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}