summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2016-04-07 15:11:58 -0400
committerM.Reynolds2016-04-07 15:11:58 -0400
commite4b37f314fad1ed4ba6a8cb251fce6470473bf65 (patch)
treef70843c9a488400493249a0bf8d60f1e5d9a74cc
downloadaur-e4b37f314fad1ed4ba6a8cb251fce6470473bf65.tar.gz
Initial upload of the spectools package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
-rw-r--r--spectool_gtk.desktop8
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5134ca8e5c38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = spectools
+ pkgdesc = Spectools is a set of utilities for using various spectrum analyzer hardware. It supports the suite of Wi-Spy devices.
+ pkgver = 201601R1
+ pkgrel = 1
+ url = https://www.kismetwireless.net/spectools/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk2
+ depends = ncurses
+ depends = pango
+ depends = libusb
+ depends = libusb-compat
+ optdepends = libtinfo: ncurses terminal graphics support
+ source = https://www.kismetwireless.net/code/spectools-2016-01-R1.tar.xz
+ source = spectool_gtk.desktop
+ sha256sums = 8d70daaf3b4b71196ca63bbd5df0ef14b82c3b496f63b5cfa434fa637dc08d57
+ sha256sums = 2ec667f8876db43463ef97628e00f2013068dc9139cf32e49ea40d2af77e71af
+
+pkgname = spectools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51618a3a8d4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: M.Reynolds
+
+pkgname=spectools
+pkgver=201601R1
+_ver=2016-01-R1
+pkgrel=1
+pkgdesc="Spectools is a set of utilities for using various spectrum analyzer
+ hardware. It supports the suite of Wi-Spy devices."
+arch=('i686' 'x86_64')
+url="https://www.kismetwireless.net/spectools/"
+license=('GPL')
+depends=('cairo' 'gdk-pixbuf2' 'glib2' 'gtk2' 'ncurses' 'pango' 'libusb' 'libusb-compat')
+optdepends=('libtinfo: ncurses terminal graphics support')
+source=("https://www.kismetwireless.net/code/$pkgname-$_ver.tar.xz" 'spectool_gtk.desktop')
+sha256sums=('8d70daaf3b4b71196ca63bbd5df0ef14b82c3b496f63b5cfa434fa637dc08d57'
+ '2ec667f8876db43463ef97628e00f2013068dc9139cf32e49ea40d2af77e71af')
+
+build () {
+ cd "$srcdir/$pkgname-$_ver"
+ CFLAGS="-std=gnu89" ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "$srcdir/$pkgname-$_ver"
+ make DESTDIR="$pkgdir" install
+
+ sed -i 's/GROUP="plugdev"/GROUP="wheel"/' 99-wispy.rules
+ install -Dm 644 99-wispy.rules "$pkgdir/usr/lib/udev/rules.d/99-wispy.rules"
+
+ cd "$srcdir"
+ install -Dm 644 spectool_gtk.desktop "$pkgdir/usr/share/applications/spectool_gtk.desktop"
+}
diff --git a/spectool_gtk.desktop b/spectool_gtk.desktop
new file mode 100644
index 000000000000..8c01d39e8f2c
--- /dev/null
+++ b/spectool_gtk.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Spectrum Tools
+Exec=spectool_gtk
+Type=Application
+Icon=radio
+Comment=2.4 GHz spectrum analysis using the Wi-Spy hardware device
+Keywords=wispy;spectrum;wireless;
+Categories=GTK;System;Monitor;