summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-03-10 23:40:50 +0000
committerJoan Bruguera Micó2024-03-10 23:40:50 +0000
commitc8a1d5b6ed88b8fdd85dca292556578e50014c2c (patch)
tree67a7948b3c85dc59e99280e04f521e8fd00c2fe8
parent12a2c2660aef1c0eaa808e35a7aa78e879876e57 (diff)
downloadaur-spectral.tar.gz
Fix build with GCC 14
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0950e192564..44d804b1938c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spectral
pkgdesc = Signal processing techniques to select representative regions from Paraver traces (from BSC).
pkgver = 3.4.1.20180918
- pkgrel = 2
+ pkgrel = 3
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index a95f9eda8fbd..40542e48f0cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='spectral'
pkgdesc='Signal processing techniques to select representative regions from Paraver traces (from BSC).'
pkgver='3.4.1.20180918'
-pkgrel='2'
+pkgrel='3'
arch=('x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPL3')
@@ -21,6 +21,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # For now, ignore new errors from GCC 14 (see https://gcc.gnu.org/gcc-14/porting_to.html)
+ export CFLAGS="$CFLAGS -Wno-error=implicit-function-declaration"
+
./configure \
--prefix=/usr \
--with-fft=/usr \
@@ -34,4 +37,4 @@ package() {
cd "$srcdir/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
-} \ No newline at end of file
+}