aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK2020-03-17 15:54:38 +0100
committerTBK2020-03-17 16:04:43 +0100
commite1c0e522c97a2a2e8aaaea17dd2ef631c0bce3ed (patch)
tree950278d5b0709b9cae3eefc5f6821095d8bf95d5
downloadaur-e1c0e522c97a2a2e8aaaea17dd2ef631c0bce3ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rw-r--r--README.md17
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29dc75bdeda3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = spectral-matrix
+ pkgdesc = Glossy cross-platform client for Matrix
+ pkgver = 817
+ pkgrel = 1
+ url = https://gitlab.com/spectral-im/spectral
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ depends = qt5-graphicaleffects
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qtkeychain
+ depends = libquotient-git
+ depends = libqtolm-git
+ conflicts = spectral-matrix-git
+ source = spectral-matrix-817.tar.gz::https://gitlab.com/spectral-im/spectral/-/archive/817/spectral-817.tar.gz
+ source = SortFilterProxyModel-36befddf5d57faad990e72c88c5844794f274145.tar.gz::https://github.com/oKcerG/SortFilterProxyModel/archive/36befddf5d57faad990e72c88c5844794f274145.tar.gz
+ sha256sums = 6888ad58282eb5baab83d7037423d22b6c2d5be60f8452168b57b39b53e6ca0d
+ sha256sums = 1f5a6c64f793e7d74e8922e071392cf33baa4e7457e70f396c1e1fcb9d63b378
+
+pkgname = spectral-matrix
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34019520fa8f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b43b0bc64a2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: TBK <aur at jjtc dot eu>
+# Contributor: TBK <aur at jjtc dot eu>
+
+pkgname=spectral-matrix
+_pkgname=spectral
+pkgver=817
+pkgrel=1
+_commit_sortfilterproxymodel="36befddf5d57faad990e72c88c5844794f274145"
+pkgdesc='Glossy cross-platform client for Matrix'
+url='https://gitlab.com/spectral-im/spectral'
+arch=('any')
+license=('GPL3')
+conflicts=('spectral-matrix-git')
+depends=('qt5-graphicaleffects' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools' 'qtkeychain' 'libquotient-git' 'libqtolm-git')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/spectral-im/spectral/-/archive/$pkgver/spectral-$pkgver.tar.gz"
+ "SortFilterProxyModel-$_commit_sortfilterproxymodel.tar.gz::https://github.com/oKcerG/SortFilterProxyModel/archive/$_commit_sortfilterproxymodel.tar.gz")
+sha256sums=('6888ad58282eb5baab83d7037423d22b6c2d5be60f8452168b57b39b53e6ca0d'
+ '1f5a6c64f793e7d74e8922e071392cf33baa4e7457e70f396c1e1fcb9d63b378')
+_builddir="$_pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ rmdir \
+ include/libQuotient \
+ include/SortFilterProxyModel
+ mv ../SortFilterProxyModel-$_commit_sortfilterproxymodel include/SortFilterProxyModel
+}
+
+build() {
+ cd "$_builddir"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_INTREE_LIBQMC=false \
+ -DGIT_FOUND=false
+ make -C build
+}
+
+package() {
+ cd "$_builddir"
+ make -C build DESTDIR="$pkgdir" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..159b67044239
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+# Spectral
+Arch User Repository Spectral - Matrix client
+
+## Update package
+
+* Update package version in PKGBUILD
+* Generate new checksums with
+
+```$ updpkgsums```
+
+* Test install
+
+```$ makepkg -si```
+
+* Update .SRCINFO
+
+```$ makepkg --printsrcinfo > .SRCINFO```