summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Magno2016-02-16 02:48:25 -0200
committerGabriel Magno2016-02-16 02:48:25 -0200
commit046c6241775a8289f008fec43c62dfca99b81d4f (patch)
tree9ac04a4be1535f56fceff3a1920f4dcd6269be3b
downloadaur-046c6241775a8289f008fec43c62dfca99b81d4f.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95dfcc231f09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Feb 16 04:48:12 UTC 2016
+pkgbase = spectro-git
+ pkgdesc = Provides BBCode formatted text with the spectrograms of audio files.
+ pkgver = r48.1714c5a
+ pkgrel = 1
+ url = https://github.com/welpo/spectro
+ arch = any
+ license = GPL3
+ depends = sox
+ depends = curl
+ optdepends = ffmpeg: to process ape, WMA, MP4 and AAC files
+ optdepends = imagemagick: to use the --compare feature
+ optdepends = optipng: to optimise the spectrograms
+ optdepends = perl: to include the file SHA on the output (shasum)
+ source = git+https://github.com/welpo/spectro.git
+ sha256sums = SKIP
+
+pkgname = spectro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff949f490e42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gabriel Magno <gabrielmagno1@gmail.com>
+
+_pkgname=spectro
+pkgname=spectro-git
+pkgver=r48.1714c5a
+pkgrel=1
+pkgdesc="Provides BBCode formatted text with the spectrograms of audio files."
+
+arch=('any')
+url="https://github.com/welpo/spectro"
+license=('GPL3')
+
+depends=('sox' 'curl')
+optdepends=('ffmpeg: to process ape, WMA, MP4 and AAC files'
+ 'imagemagick: to use the --compare feature'
+ 'optipng: to optimise the spectrograms'
+ 'perl: to include the file SHA on the output (shasum)')
+
+source=("git+https://github.com/welpo/spectro.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "spectro" "$pkgdir/usr/bin/spectro"
+}