summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2019-01-23 20:57:11 +0100
committerBjoern Franke2019-01-23 20:57:11 +0100
commit4f9672cf6aa0cf9a2dbc10ea9b151d83dd60b678 (patch)
treec045aee71b673ae48615e46e40d6f4168baa0d8d
parenta884252d7d61b8da94d39c5d5c2c8e6578e8c523 (diff)
downloadaur-4f9672cf6aa0cf9a2dbc10ea9b151d83dd60b678.tar.gz
patch for building with boost 1.69
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--boost.patch22
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d377a862f43..a32a8084331a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spectrum2
pkgdesc = an open source instant messaging transport
pkgver = 2.0.9
- pkgrel = 2
+ pkgrel = 3
url = http://spectrum.im
arch = any
license = GPL
@@ -41,8 +41,10 @@ pkgbase = spectrum2
optdepends = libev: LibPurple backend support - libev eventloop
source = https://github.com/hanzz/spectrum2/archive/2.0.9.tar.gz
source = spectrum2.service
+ source = boost.patch
sha256sums = e536a65ef86aafdc6d87f3c6b5bce919a67054dd01f757a2dbc82acbbdd0fa87
sha256sums = 8b95ddcf90449dcd0dec111276c69d04a92d09a0f9e1815009b2179a8050c9d1
+ sha256sums = e73973fdc07b448170c1ce7d252af900fd8c68defe67f0876693d2ea8b4ba97c
pkgname = spectrum2
diff --git a/PKGBUILD b/PKGBUILD
index 15b6e5161b08..30cd69902deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=spectrum2
pkgver=2.0.9
-pkgrel=2
+pkgrel=3
#epoch=
pkgdesc="an open source instant messaging transport"
arch=('any')
@@ -32,14 +32,21 @@ options=()
install=
changelog=
source=("https://github.com/hanzz/$pkgname/archive/$pkgver.tar.gz"
- 'spectrum2.service')
+ 'spectrum2.service'
+ 'boost.patch')
sha256sums=('e536a65ef86aafdc6d87f3c6b5bce919a67054dd01f757a2dbc82acbbdd0fa87'
- '8b95ddcf90449dcd0dec111276c69d04a92d09a0f9e1815009b2179a8050c9d1')
+ '8b95ddcf90449dcd0dec111276c69d04a92d09a0f9e1815009b2179a8050c9d1'
+ 'e73973fdc07b448170c1ce7d252af900fd8c68defe67f0876693d2ea8b4ba97c')
noextract=()
validpgpkeys=()
+prepare() {
+ cd "$srcdir"
+ patch -p1 -d "$pkgname-$pkgver" < boost.patch
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
cmake . -DCMAKE_BUILD_TYPE=Debug -DCMAKE_CXX_STANDARD=14 -DCMAKE_INSTALL_PREFIX=/usr -DSPECTRUM_VERSION=${pkgver} -DIRC_INCLUDE_DIR=/usr/include/qt/Communi
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..380c9a4ce531
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,22 @@
+From dca109b1f3a688f1d0ce2d2be54d5598c59bf6fb Mon Sep 17 00:00:00 2001
+From: Vitaly Takmazov <vitalyster@gmail.com>
+Date: Wed, 23 Jan 2019 15:10:00 +0300
+Subject: [PATCH] CMake: no need to find boost signals
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9411d274..5680fc0a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -88,7 +88,7 @@ if (WIN32)
+ add_definitions(-DBOOST_ALL_NO_LIB)
+ endif(WIN32)
+ set(Boost_FIND_QUIETLY ON)
+- find_package(Boost COMPONENTS program_options date_time system filesystem regex thread signals locale REQUIRED)
++ find_package(Boost COMPONENTS program_options date_time system filesystem regex thread locale REQUIRED)
+
+ message( STATUS "Found Boost: ${Boost_VERSION}, ${Boost_LIBRARIES}, ${Boost_INCLUDE_DIR}")
+