summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-12-27 14:04:38 +0300
committerCaleb Maclennan2023-12-27 14:04:38 +0300
commit25019c48f04388fc8ad3da962a4d6ca672a9540b (patch)
tree905fb04c89187c809f880c02281d67cfc1312f7c
downloadaur-25019c48f04388fc8ad3da962a4d6ca672a9540b.tar.gz
Initial upload: speedata-publisher 4.15.19-0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f64d998486a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = speedata-publisher
+ pkgdesc = a database publishing software that creates high-quality layouted PDFs fully automatically
+ pkgver = 4.15.19
+ pkgrel = 0
+ url = https://github.com/speedata/publisher
+ arch = x86_64
+ license = AGPL3
+ makedepends = go
+ makedepends = lua
+ makedepends = ruby-rake
+ depends = glibc
+ source = https://github.com/speedata/publisher/archive/7d1037fdd9b002ba53c8352d8ef67b7e552f3599/publisher-7d1037fdd9b002ba53c8352d8ef67b7e552f3599.tar.gz
+ sha256sums = 634ea7abecec41c83d3e7c5cce81a1be22e7e81dbb0b01610810dc89230237d0
+
+pkgname = speedata-publisher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94fceb0faf4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+# Upstream repository is missing tags:
+# https://github.com/speedata/publisher/issues/550
+_sha=7d1037fdd9b002ba53c8352d8ef67b7e552f3599
+
+pkgname=speedata-publisher
+pkgver=4.15.19
+pkgrel=0
+pkgdesc='a database publishing software that creates high-quality layouted PDFs fully automatically'
+arch=(x86_64)
+url='https://github.com/speedata/publisher'
+license=(AGPL3)
+depends=(glibc)
+makedepends=(go
+ lua
+ ruby-rake)
+_archive="${pkgname#*-}-$_sha"
+source=("$url/archive/$_sha/$_archive.tar.gz")
+sha256sums=('634ea7abecec41c83d3e7c5cce81a1be22e7e81dbb0b01610810dc89230237d0')
+
+prepare() {
+ cd "$_archive"
+ # sed -i \
+ # -e '/^installdir/s!__FILE__!"/usr/bin"!' \
+ # -e '/^srcdir/as!"src"!"share/speedata"!' \
+ # Rakefile
+}
+
+build() {
+ cd "$_archive"
+ rake build
+ rake buildlib
+}
+
+package() {
+ cd "$_archive"
+ # Upstream project has no installation targets
+ # https://github.com/speedata/publisher/issues/551
+ # rake install
+ install -Dm0755 -t "$pkgdir/usr/bin/" bin/sp
+}