summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-01-04 09:58:11 +0300
committerCaleb Maclennan2024-01-04 09:58:11 +0300
commit3b0d6410fc3a8d02f4775df67659a7ad00d7fa04 (patch)
tree348470020ae70654a79409aea0373a0917aadf42
parent25019c48f04388fc8ad3da962a4d6ca672a9540b (diff)
downloadaur-3b0d6410fc3a8d02f4775df67659a7ad00d7fa04.tar.gz
upgpkg: speedata-publisher 4.15.20-0
Start working out font dependencies and installing bits that go somewhere
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f64d998486a..1faf87ef38db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = speedata-publisher
pkgdesc = a database publishing software that creates high-quality layouted PDFs fully automatically
- pkgver = 4.15.19
+ pkgver = 4.15.20
pkgrel = 0
url = https://github.com/speedata/publisher
arch = x86_64
@@ -8,8 +8,14 @@ pkgbase = speedata-publisher
makedepends = go
makedepends = lua
makedepends = ruby-rake
+ depends = crimson-pro-font
depends = glibc
- source = https://github.com/speedata/publisher/archive/7d1037fdd9b002ba53c8352d8ef67b7e552f3599/publisher-7d1037fdd9b002ba53c8352d8ef67b7e552f3599.tar.gz
- sha256sums = 634ea7abecec41c83d3e7c5cce81a1be22e7e81dbb0b01610810dc89230237d0
+ depends = tex-gyre-fonts
+ depends = tex-gyre-fonts
+ depends = ttf-camingocode
+ provides = libsplib.so
+ provides = luaglue.so
+ source = https://github.com/speedata/publisher/archive/v4.15.20/publisher-4.15.20.tar.gz
+ sha256sums = ab37e2aa8d91071dd13a601385403802c34ebeb69eda1b092ad5e4231a310832
pkgname = speedata-publisher
diff --git a/PKGBUILD b/PKGBUILD
index 94fceb0faf4f..4cf7fdc96318 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-# Upstream repository is missing tags:
-# https://github.com/speedata/publisher/issues/550
-_sha=7d1037fdd9b002ba53c8352d8ef67b7e552f3599
-
pkgname=speedata-publisher
-pkgver=4.15.19
+pkgver=4.15.20
pkgrel=0
pkgdesc='a database publishing software that creates high-quality layouted PDFs fully automatically'
arch=(x86_64)
url='https://github.com/speedata/publisher'
license=(AGPL3)
-depends=(glibc)
+depends=(crimson-pro-font
+ glibc
+ tex-gyre-fonts
+ tex-gyre-fonts
+ ttf-camingocode)
makedepends=(go
lua
ruby-rake)
-_archive="${pkgname#*-}-$_sha"
-source=("$url/archive/$_sha/$_archive.tar.gz")
-sha256sums=('634ea7abecec41c83d3e7c5cce81a1be22e7e81dbb0b01610810dc89230237d0')
+provides=(libsplib.so
+ luaglue.so)
+_archive="${pkgname#*-}-$pkgver"
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('ab37e2aa8d91071dd13a601385403802c34ebeb69eda1b092ad5e4231a310832')
prepare() {
cd "$_archive"
@@ -39,4 +41,6 @@ package() {
# https://github.com/speedata/publisher/issues/551
# rake install
install -Dm0755 -t "$pkgdir/usr/bin/" bin/sp
+ install -Dm0755 -t "$pkgdir/usr/lib/" build/dylib/{luaglue,libsplib}.so
+ install -Dm0644 -t "$pkgdir/usr/include/" build/dylib/libsplib.h
}