summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-07-06 20:06:56 -0400
committerMario Finelli2015-07-06 20:06:56 -0400
commit1ea45d7c984dcfc2fbc45c0a7a76153d2230182e (patch)
tree902323c9874414957b73a4999e9bfffa03953c65
downloadaur-1ea45d7c984dcfc2fbc45c0a7a76153d2230182e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..108b97684cbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = speedread-git
+ pkgdesc = A simple terminal-based open source Spritz-alike.
+ pkgver = r26.6d1c5eb
+ pkgrel = 1
+ url = https://github.com/pasky/speedread
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = speedread
+ conflicts = speedread
+ source = git://github.com/pasky/speedread.git
+ md5sums = SKIP
+
+pkgname = speedread-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c63a0f329a43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+pkgname=speedread-git
+pkgver=r26.6d1c5eb
+pkgrel=1
+pkgdesc="A simple terminal-based open source Spritz-alike."
+arch=('i686' 'x86_64')
+url="https://github.com/pasky/speedread"
+license=('MIT')
+makedepends=('git')
+provides=('speedread')
+conflicts=('speedread')
+source=('git://github.com/pasky/speedread.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/speedread"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "$srcdir/speedread"
+ install -Dm0755 speedread "$pkgdir"/usr/bin/speedread
+ install -Dm0644 LICENCE "$pkgdir"/usr/share/licenses/speedread/LICENSE
+}