summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaughan Milliman2023-01-25 21:07:18 -0600
committerVaughan Milliman2023-01-25 21:07:18 -0600
commit6087f7723c2cf506c7fc3893063ca85fc211ec42 (patch)
tree97d85debe89338dc601b18b9855219f302e443b8
downloadaur-6087f7723c2cf506c7fc3893063ca85fc211ec42.tar.gz
intial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.install3
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ca4bc03fe36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = speedrun
+ pkgdesc = Run your games extra fast with speedrun
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/zeroxoneafour/speedrun
+ install = .install
+ arch = any
+ license = MIT
+ optdepends = mangohud: mangohud support
+ optdepends = gamemode: gamemoderun support
+ optdepends = nvidia-prime: prime-run support
+ source = speedrun::git+https://github.com/zeroxoneafour/speedrun
+ sha256sums = SKIP
+
+pkgname = speedrun
diff --git a/.install b/.install
new file mode 100644
index 000000000000..ccc57b4026e5
--- /dev/null
+++ b/.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Edit systemwide configuration in /etc/speedrun.conf or user configuration in $XDG_CONFIG_HOME/speedrun/speedrun.conf"
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb7b8ff8369b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname="speedrun"
+pkgver=0.1.0
+pkgrel=1
+arch=("any")
+url="https://github.com/zeroxoneafour/speedrun"
+pkgdesc="Run your games extra fast with speedrun"
+license=("MIT")
+optdepends=("mangohud: mangohud support" "gamemode: gamemoderun support" "nvidia-prime: prime-run support")
+source=("$pkgname::git+https://github.com/zeroxoneafour/speedrun")
+sha256sums=("SKIP")
+install=".install"
+
+pkgver() {
+ cd $pkgname
+ echo $(grep -Po "version=\d+\.\d+\.\d+" speedrun.sh | grep -Po "\d+\.\d+\.\d+")
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "speedrun.sh" "$pkgdir/usr/bin/speedrun"
+ install -D -m755 "speedrun.conf" "$pkgdir/etc/speedrun.conf"
+}