summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2015-06-09 17:36:16 +0100
committerJohn Lane2015-06-09 17:36:16 +0100
commit15f896f2dd1da5c63cc5572c9e79b791944ab9a9 (patch)
treef56a9c1ade00852aafb5d3d9341335fc2542efce
downloadaur-speedtouch-tools.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
3 files changed, 54 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..b4ccb45ada77
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = speedtouch-tools
+ pkgdesc = Speedtouch 585 Router Admin Tools for the Linux command-line
+ pkgver = r10.ba00e03
+ pkgrel = 1
+ url = https://github.com/johnlane/speedtouch-tools
+ arch = any
+ license = MIT
+ depends = python
+ depends = bash
+ source = git+https://github.com/johnlane/speedtouch-tools.git
+
+pkgname = speedtouch-tools
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93e369719d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = speedtouch-tools
+ pkgdesc = Speedtouch 585 Router Admin Tools for the Linux command-line
+ pkgver = r10.ba00e03
+ pkgrel = 1
+ url = https://github.com/johnlane/speedtouch-tools
+ arch = any
+ license = MIT
+ depends = python
+ depends = bash
+ source = git+https://github.com/johnlane/speedtouch-tools.git
+ md5sums = SKIP
+
+pkgname = speedtouch-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9616f87a5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: John Lane <archlinux at jelmail dot com>
+#
+# Speedtouch Admin Tools for Linux
+
+pkgname=speedtouch-tools
+pkgver=r10.ba00e03
+pkgrel=1
+pkgdesc="Speedtouch 585 Router Admin Tools for the Linux command-line"
+arch=(any)
+url='https://github.com/johnlane/speedtouch-tools'
+license=('MIT')
+depends=(python bash)
+
+source=('git+https://github.com/johnlane/speedtouch-tools.git')
+
+md5sums=('SKIP')
+
+package() {
+ install -dm755 $pkgdir/usr/{bin,lib/stt}
+ install ${srcdir}/${pkgname}/bin/* $pkgdir/usr/bin
+ install ${srcdir}/${pkgname}/lib/stt/* $pkgdir/usr/lib/stt
+}
+
+pkgver() {
+ cd "$srcdir/speedtouch-tools"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}