summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-31 15:36:21 +0800
committerChocobo12019-05-31 15:38:17 +0800
commite2a8676776803d333532656954973ae69d04f826 (patch)
tree3c22808b448582aab02882dfe290ff2e58f4108c
parentc22a6fc6607c993001b2bc0c46edadbcd7a6d2d3 (diff)
downloadaur-e2a8676776803d333532656954973ae69d04f826.tar.gz
upgpkg: speex-git 1.2.0.r10.g6e04bfa-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8298abb406ed..956dda8e5c86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = speex-git
pkgdesc = An patent-free audio compression format designed for speech
- pkgver = 1.2.0.r1.gcae5026
+ pkgver = 1.2.0.r10.g6e04bfa
pkgrel = 1
url = https://www.speex.org/
arch = i686
@@ -8,9 +8,11 @@ pkgbase = speex-git
license = BSD
makedepends = git
depends = glibc
+ depends = libogg
+ depends = speexdsp
provides = speex
conflicts = speex
- source = git+https://git.xiph.org/speex.git
+ source = git+https://gitlab.xiph.org/xiph/speex.git
sha256sums = SKIP
pkgname = speex-git
diff --git a/PKGBUILD b/PKGBUILD
index 8c6997f04cab..4baa071ea5ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=speex-git
-pkgver=1.2.0.r1.gcae5026
+pkgver=1.2.0.r10.g6e04bfa
pkgrel=1
pkgdesc="An patent-free audio compression format designed for speech"
arch=('i686' 'x86_64')
url="https://www.speex.org/"
license=('BSD')
-depends=('glibc')
+depends=('glibc' 'libogg' 'speexdsp')
makedepends=('git')
provides=('speex')
conflicts=('speex')
-source=("git+https://git.xiph.org/speex.git")
+source=("git+https://gitlab.xiph.org/xiph/speex.git")
sha256sums=('SKIP')
@@ -25,7 +25,9 @@ build() {
cd "speex"
./autogen.sh
- ./configure --prefix="/usr" --enable-binaries
+ ./configure \
+ --prefix="/usr" \
+ --enable-binaries
make
}
@@ -33,5 +35,5 @@ package() {
cd "speex"
make DESTDIR="$pkgdir" install
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/speex/COPYING"
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/speex"
}