summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoshless2018-05-30 14:45:52 +0200
committerRoshless2018-05-30 14:45:52 +0200
commit06277475a3ad34fb2089df112acf498563dd950c (patch)
treed8529fa3aeb26ccc6d5b653140c68d730332b83c
downloadaur-06277475a3ad34fb2089df112acf498563dd950c.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36d2b97f13a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = spek-alternative
+ pkgdesc = An acoustic spectrum analyser.
+ pkgver = 0.8.2.3
+ pkgrel = 1
+ url = https://github.com/withmorten/spek-alternative
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ depends = desktop-file-utils
+ depends = ffmpeg
+ depends = wxgtk
+ provides = spek
+ conflicts = spek
+ conflicts = spec-git
+ source = https://github.com/withmorten/spek-alternative/archive/0.8.2.3.tar.gz
+ md5sums = e7b7ce256e1712b6d22ddbf5892013a5
+
+pkgname = spek-alternative
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b1b1a88babe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Roshless <aur@roshless.com>
+pkgname=spek-alternative
+pkgver=0.8.2.3
+pkgrel=1
+pkgdesc='An acoustic spectrum analyser.'
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+url='https://github.com/withmorten/spek-alternative'
+license=('GPL3')
+depends=('desktop-file-utils' 'ffmpeg' 'wxgtk')
+provides=('spek')
+conflicts=('spek' 'spec-git')
+makedepends=('intltool')
+source=("https://github.com/withmorten/spek-alternative/archive/$pkgver.tar.gz")
+md5sums=('e7b7ce256e1712b6d22ddbf5892013a5')
+
+build()
+{
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+