summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Grunbaum2022-10-07 01:47:37 +0000
committerJoel Grunbaum2022-10-07 01:47:37 +0000
commitea8c8cb6c84c9329e93cffe247215379b034cf25 (patch)
tree6dd4fe7c0c76daeb195c65d6cdf7e08c6501bd90
downloadaur-spek-x-git.tar.gz
Created package
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baab0548211c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = spek-x-git
+ pkgdesc = Acoustic spectrum analyser forked from spek.
+ pkgver = v0.9.0.r2.g5ed0a19
+ pkgrel = 1
+ url = https://github.com/MikeWang000000/spek-X
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = automake
+ makedepends = intltool
+ makedepends = gettext
+ depends = ffmpeg
+ depends = wxgtk3
+ provides = spek
+ conflicts = spek
+ source = spek-x-git::git+https://github.com/MikeWang000000/spek-X
+ md5sums = SKIP
+
+pkgname = spek-x-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffa5c9d472e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joel Grunbaum <joelgrun@gmail.com>
+
+pkgname=spek-x-git
+pkgver=v0.9.0.r2.g5ed0a19
+pkgrel=1
+pkgdesc='Acoustic spectrum analyser forked from spek.'
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+license=('GPL3')
+depends=('ffmpeg' 'wxgtk3')
+makedepends=('git' 'pkgconfig' 'automake' 'intltool' 'gettext')
+url='https://github.com/MikeWang000000/spek-X'
+conflicts=('spek')
+provides=('spek')
+source=('spek-x-git::git+https://github.com/MikeWang000000/spek-X')
+md5sums=('SKIP')
+options=()
+
+pkgver() {
+ cd $pkgname
+ git describe --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=$pkgdir install
+}