summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Pintarelli2019-10-26 19:21:57 +0200
committerSimon Pintarelli2019-10-26 19:27:06 +0200
commit7c9de5da747213c3bf8e29abd3f881785bee4176 (patch)
treeb4b754d4995fe211ee140ef78e708b955803757b
downloadaur-spfft-cuda-git.tar.gz
spfft-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cf0030a8dcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = spfft-cuda-git
+ pkgdesc = 3D FFT used in plane-wave DFT codes.
+ pkgver = r31.69e08b7
+ pkgrel = 1
+ url = https://github.com/eth-cscs/spFFT
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = fftw
+ depends = cuda
+ depends = openmpi
+ provides = spFFT
+ options = staticlibs
+ source = spfft::git+https://github.com/eth-cscs/spFFT.git#branch=master
+ sha256sums = SKIP
+
+pkgname = spfft-cuda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93b962b41f7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# vim:set ts=2 sw
+# Maintainer: Simon Pintarelli <simon.pintarelli@cscs.ch>
+pkgname=spfft-cuda-git
+_pkgname=spfft
+pkgver=r31.69e08b7
+pkgrel=1
+pkgdesc="3D FFT used in plane-wave DFT codes."
+arch=('i686' 'x86_64')
+url="https://github.com/eth-cscs/spFFT"
+license=('GPL')
+depends=(fftw cuda openmpi)
+makedepends=(cmake)
+provides=('spFFT')
+options=('staticlibs')
+source=("${_pkgname}::git+https://github.com/eth-cscs/spFFT.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DSPFFT_OMP=On \
+ -DSPFFT_MPI=On \
+ -DSPFFT_GPU_BACKEND=CUDA \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: