summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsph2015-08-11 18:54:19 +0000
committersph2015-08-11 18:54:19 +0000
commit64a2aa74da9da85cfbead68be74629d1f6286756 (patch)
tree5cbd94ea04aaf0e0086dc1affddb6d669647e7b5
downloadaur-64a2aa74da9da85cfbead68be74629d1f6286756.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90ba339a6bb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sph-pack-git
+ pkgdesc = free software file packaging solution. compounding/compression/encryption and the rerverse with only one standard file format per task
+ pkgver = e43ba6d
+ pkgrel = 1
+ url = http://sph.mn
+ arch = any
+ license = gpl3
+ makedepends = git
+ depends = sph-lib
+ depends = tar
+ depends = xz
+ depends = scrypt
+ provides = pack
+ conflicts = sph-pack
+ source = git://sph.mn/sph-pack
+ md5sums = SKIP
+
+pkgname = sph-pack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ee89e88af0fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=sph-pack-git
+_gitname=sph-pack
+pkgver=e43ba6d
+pkgrel=1
+pkgdesc="free software file packaging solution. compounding/compression/encryption and the rerverse with only one standard file format per task"
+arch=(any)
+license=(gpl3)
+makedepends=(git)
+provides=(pack)
+depends=(sph-lib tar xz scrypt)
+conflicts=(sph-pack)
+source=("git://sph.mn/sph-pack")
+url="http://sph.mn"
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_gitname
+ git log -n 1 --pretty=format:"%h"
+}
+
+package() {
+ cd $_gitname
+ ./exec/install "$pkgdir"
+}