summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-12-03 20:04:05 +0100
committerMartchus2021-12-03 20:04:05 +0100
commite6cf223e390bf675563b80e317f7cd2a14b5a9a1 (patch)
tree2b4d5a5bf375eea990888f22ffa90c59ea966615
parent1afdeed747cddb42f9c73dd4da404ec2227255b6 (diff)
downloadaur-sphinxbase.tar.gz
Rebuild against Python 3.10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--avoid-python3.10-warning.patch141
3 files changed, 149 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c428885dd268..75eafc65ce6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sphinxbase
pkgdesc = Common library for sphinx speech recognition
pkgver = 5prealpha
- pkgrel = 12
- url = http://cmusphinx.sourceforge.net/
+ pkgrel = 13
+ url = https://cmusphinx.sourceforge.net/
arch = i686
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 74b5926e524b..821fff8c8ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=sphinxbase
pkgver=5prealpha
-pkgrel=12
+pkgrel=13
pkgdesc='Common library for sphinx speech recognition'
-url='http://cmusphinx.sourceforge.net/'
+url='https://cmusphinx.sourceforge.net/'
arch=('i686' 'x86_64')
license=('BSD')
makedepends=('bison' 'swig')
@@ -22,15 +22,16 @@ options=('!libtool')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Reconfiguring project for current version of Automake"
- autoreconf -ivf > /dev/null
patch -p1 -b -i ../sphinxbase-5prealpha-fix-doxy2swig.patch
+
+ echo "Reconfiguring project for current version of Automake"
+ autoreconf -ivf > /dev/null
}
build() {
cd "${pkgname}-${pkgver}"
- export PYTHON=/usr/bin/python
+ export PYTHON=/usr/bin/python PYTHONWARNINGS=ignore
./configure --prefix=/usr
make
}
diff --git a/avoid-python3.10-warning.patch b/avoid-python3.10-warning.patch
new file mode 100644
index 000000000000..0891f246862b
--- /dev/null
+++ b/avoid-python3.10-warning.patch
@@ -0,0 +1,141 @@
+From e0221880ccdd79ed9bf42937a56a4c319b013576 Mon Sep 17 00:00:00 2001
+From: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Thu, 11 Nov 2021 21:06:59 +0100
+Subject: [PATCH] Update ax_python_devel.m4
+
+Notably python3.10's distutils emits a warning when getting imported.
+This was making the old ax_python_devel.m4 fail.
+---
+ m4/ax_python_devel.m4 | 37 ++++++++++++++++++++-----------------
+ 1 file changed, 20 insertions(+), 17 deletions(-)
+
+diff --git a/m4/ax_python_devel.m4 b/m4/ax_python_devel.m4
+index 59a2ff09..44dbd83e 100644
+--- a/m4/ax_python_devel.m4
++++ b/m4/ax_python_devel.m4
+@@ -1,5 +1,5 @@
+ # ===========================================================================
+-# http://www.gnu.org/software/autoconf-archive/ax_python_devel.html
++# https://www.gnu.org/software/autoconf-archive/ax_python_devel.html
+ # ===========================================================================
+ #
+ # SYNOPSIS
+@@ -12,8 +12,8 @@
+ # in your configure.ac.
+ #
+ # This macro checks for Python and tries to get the include path to
+-# 'Python.h'. It provides the $(PYTHON_CPPFLAGS) and $(PYTHON_LDFLAGS)
+-# output variables. It also exports $(PYTHON_EXTRA_LIBS) and
++# 'Python.h'. It provides the $(PYTHON_CPPFLAGS) and $(PYTHON_LIBS) output
++# variables. It also exports $(PYTHON_EXTRA_LIBS) and
+ # $(PYTHON_EXTRA_LDFLAGS) for embedding Python in your code.
+ #
+ # You can search for some particular version of Python by passing a
+@@ -52,7 +52,7 @@
+ # Public License for more details.
+ #
+ # You should have received a copy of the GNU General Public License along
+-# with this program. If not, see <http://www.gnu.org/licenses/>.
++# with this program. If not, see <https://www.gnu.org/licenses/>.
+ #
+ # As a special exception, the respective Autoconf Macro's copyright owner
+ # gives unlimited permission to copy, distribute and modify the configure
+@@ -67,7 +67,7 @@
+ # modified version of the Autoconf Macro, you may extend this special
+ # exception to the GPL to apply to your modified version as well.
+
+-#serial 17
++#serial 21
+
+ AU_ALIAS([AC_PYTHON_DEVEL], [AX_PYTHON_DEVEL])
+ AC_DEFUN([AX_PYTHON_DEVEL],[
+@@ -99,7 +99,7 @@ AC_DEFUN([AX_PYTHON_DEVEL],[
+ This version of the AC@&t@_PYTHON_DEVEL macro
+ doesn't work properly with versions of Python before
+ 2.1.0. You may need to re-run configure, setting the
+-variables PYTHON_CPPFLAGS, PYTHON_LDFLAGS, PYTHON_SITE_PKG,
++variables PYTHON_CPPFLAGS, PYTHON_LIBS, PYTHON_SITE_PKG,
+ PYTHON_EXTRA_LIBS and PYTHON_EXTRA_LDFLAGS by hand.
+ Moreover, to disable this check, set PYTHON_NOVERSIONCHECK
+ to something else than an empty string.
+@@ -137,7 +137,7 @@ variable to configure. See ``configure --help'' for reference.
+ #
+ AC_MSG_CHECKING([for the distutils Python package])
+ ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
+- if test -z "$ac_distutils_result"; then
++ if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+@@ -172,7 +172,7 @@ $ac_distutils_result])
+ # Check for Python library path
+ #
+ AC_MSG_CHECKING([for Python library path])
+- if test -z "$PYTHON_LDFLAGS"; then
++ if test -z "$PYTHON_LIBS"; then
+ # (makes two attempts to ensure we've got a version number
+ # from the interpreter)
+ ac_python_version=`cat<<EOD | $PYTHON -
+@@ -227,25 +227,25 @@ EOD`
+ then
+ # use the official shared library
+ ac_python_library=`echo "$ac_python_library" | sed "s/^lib//"`
+- PYTHON_LDFLAGS="-L$ac_python_libdir -l$ac_python_library"
++ PYTHON_LIBS="-L$ac_python_libdir -l$ac_python_library"
+ else
+ # old way: use libpython from python_configdir
+ ac_python_libdir=`$PYTHON -c \
+ "from distutils.sysconfig import get_python_lib as f; \
+ import os; \
+ print (os.path.join(f(plat_specific=1, standard_lib=1), 'config'));"`
+- PYTHON_LDFLAGS="-L$ac_python_libdir -lpython$ac_python_version"
++ PYTHON_LIBS="-L$ac_python_libdir -lpython$ac_python_version"
+ fi
+
+- if test -z "PYTHON_LDFLAGS"; then
++ if test -z "PYTHON_LIBS"; then
+ AC_MSG_ERROR([
+ Cannot determine location of your Python DSO. Please check it was installed with
+- dynamic libraries enabled, or try setting PYTHON_LDFLAGS by hand.
++ dynamic libraries enabled, or try setting PYTHON_LIBS by hand.
+ ])
+ fi
+ fi
+- AC_MSG_RESULT([$PYTHON_LDFLAGS])
+- AC_SUBST([PYTHON_LDFLAGS])
++ AC_MSG_RESULT([$PYTHON_LIBS])
++ AC_SUBST([PYTHON_LIBS])
+
+ #
+ # Check for site packages
+@@ -288,8 +288,10 @@ EOD`
+ AC_MSG_CHECKING([consistency of all components of python development environment])
+ # save current global flags
+ ac_save_LIBS="$LIBS"
++ ac_save_LDFLAGS="$LDFLAGS"
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- LIBS="$ac_save_LIBS $PYTHON_LDFLAGS $PYTHON_EXTRA_LDFLAGS $PYTHON_EXTRA_LIBS"
++ LIBS="$ac_save_LIBS $PYTHON_LIBS $PYTHON_EXTRA_LIBS $PYTHON_EXTRA_LIBS"
++ LDFLAGS="$ac_save_LDFLAGS $PYTHON_EXTRA_LDFLAGS"
+ CPPFLAGS="$ac_save_CPPFLAGS $PYTHON_CPPFLAGS"
+ AC_LANG_PUSH([C])
+ AC_LINK_IFELSE([
+@@ -300,6 +302,7 @@ EOD`
+ # turn back to default flags
+ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
++ LDFLAGS="$ac_save_LDFLAGS"
+
+ AC_MSG_RESULT([$pythonexists])
+
+@@ -307,8 +310,8 @@ EOD`
+ AC_MSG_FAILURE([
+ Could not link test program to Python. Maybe the main Python library has been
+ installed in some non-standard library path. If so, pass it to configure,
+- via the LDFLAGS environment variable.
+- Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
++ via the LIBS environment variable.
++ Example: ./configure LIBS="-L/usr/non-standard-path/python/lib"
+ ============================================================================
+ ERROR!
+ You probably have to install the development version of the Python package