summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2016-06-01 12:00:08 +0200
committerMarco Pompili2016-06-01 12:00:08 +0200
commitfacbac09e7e8a592f615b39756b88c832398c782 (patch)
tree5877d72d7c5d8710aba02661dccd916063ed49a8
parent8976d4fda28cf6d7eae2dda0ae6424bf8dff4c0d (diff)
downloadaur-facbac09e7e8a592f615b39756b88c832398c782.tar.gz
add timing-fix patch
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--timing-fix.patch23
3 files changed, 45 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5594d269a8c7..6f7dedec4cad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 14:25:22 UTC 2016
+# Wed Jun 1 09:59:21 UTC 2016
pkgbase = sphinxbase
pkgdesc = Common library for sphinx speech recognition.
pkgver = 5prealpha
- pkgrel = 4
+ pkgrel = 5
url = http://cmusphinx.sourceforge.net/
arch = i686
arch = x86_64
license = BSD
makedepends = bison
makedepends = swig
+ depends = python2
+ depends = python
depends = lapack
depends = libpulse
- depends = libsamplerate
options = !libtool
source = http://downloads.sourceforge.net/project/cmusphinx/sphinxbase/5prealpha/sphinxbase-5prealpha.tar.gz
source = https://raw.githubusercontent.com/cmusphinx/sphinxbase/master/LICENSE
- md5sums = ea27ea80bc14b96ad0a55fd5c94025d5
- md5sums = 469fd92fa8cd1d4ca7ee0fe7435af689
+ source = timing-fix.patch
+ sha256sums = 06971dbe272d2f73bde0ef7b3538c0c8f8ea885cb171fd6b17a5975bced66e64
+ sha256sums = 5b76875102967d5f9aed1c453489d828173968086933c4bad656780830f7454f
+ sha256sums = 5e8b2bac5d9f84a1c7b7fd774ef2b3f8f6cfc9dcb415b10a66ef439f91f3d4c5
pkgname = sphinxbase
diff --git a/PKGBUILD b/PKGBUILD
index 660578f527bc..f1073c5b9d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
-# Maintainer: Marco Pompili < marcs (dot) pompili (at) gmail (dot) com >
+# Maintainer: Marco Pompili <aur AT emarcs DOT org>
# Contributor: Giorgio Gilestro crocowhile@gmail.com
+# Contributor: Martchus <martchus@gmx.net>
+# Contributor: Mladen Milinkovic <maxrd2@smoothware.net>
pkgname=sphinxbase
pkgver=5prealpha
-pkgrel=4
+pkgrel=5
pkgdesc='Common library for sphinx speech recognition.'
url='http://cmusphinx.sourceforge.net/'
arch=('i686' 'x86_64')
license=('BSD')
makedepends=('bison' 'swig')
-depends=('lapack' 'libpulse' 'libsamplerate') #not sure if libsamplerate is needed
+depends=('python2' 'python' 'lapack' 'libpulse') # not sure if libsamplerate is needed 'libsamplerate'
source=("http://downloads.sourceforge.net/project/cmusphinx/${pkgname}/${pkgver}/$pkgname-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/cmusphinx/sphinxbase/master/LICENSE")
-md5sums=('ea27ea80bc14b96ad0a55fd5c94025d5'
- '469fd92fa8cd1d4ca7ee0fe7435af689')
+ "https://raw.githubusercontent.com/cmusphinx/sphinxbase/master/LICENSE"
+ "timing-fix.patch")
+sha256sums=('06971dbe272d2f73bde0ef7b3538c0c8f8ea885cb171fd6b17a5975bced66e64'
+ '5b76875102967d5f9aed1c453489d828173968086933c4bad656780830f7454f'
+ '5e8b2bac5d9f84a1c7b7fd774ef2b3f8f6cfc9dcb415b10a66ef439f91f3d4c5')
options=('!libtool')
prepare() {
cd "$pkgname-$pkgver"
- msg2 "Reconfiguring project for Automake v1.15"
+ msg2 "Applying timing fix patch"
+ patch -p1 < "$srcdir/timing-fix.patch"
+
+ msg2 "Reconfiguring project for current version of Automake"
autoreconf -ivf > /dev/null
cd ..
diff --git a/timing-fix.patch b/timing-fix.patch
new file mode 100644
index 000000000000..6c44e856fbb3
--- /dev/null
+++ b/timing-fix.patch
@@ -0,0 +1,23 @@
+commit a1d18a46aeec2022e64fa1b11b08b5721bc9f98f
+Author: Mladen Milinkovic <max@smoothware.net>
+Date: Fri May 20 04:45:53 2016 +0200
+
+ fe_process_frames_ext() wasn't updating fe sample_counter in some cases
+
+ When there wasn't enough samples in buffer to fill one frame,
+ sample_counter wasn't updated with samples that were stored in overflow
+ buffer.
+
+diff --git a/src/libsphinxbase/fe/fe_interface.c b/src/libsphinxbase/fe/fe_interface.c
+index 1cc3566..d090b6e 100644
+--- a/src/libsphinxbase/fe/fe_interface.c
++++ b/src/libsphinxbase/fe/fe_interface.c
+@@ -471,6 +471,8 @@ fe_process_frames_ext(fe_t *fe,
+ memcpy(fe->overflow_samps + fe->num_overflow_samps,
+ *inout_spch, *inout_nsamps * (sizeof(int16)));
+ fe->num_overflow_samps += *inout_nsamps;
++ /* Update global sample counter with number of samples */
++ fe->sample_counter += *inout_nsamps;
+ /* Update input-output pointers and counters. */
+ *inout_spch += *inout_nsamps;
+ *inout_nsamps = 0;