summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2021-01-18 12:11:32 +0100
committerLubosz Sarnecki2021-01-18 12:14:31 +0100
commit20a9621657b672ffafd203e90d0308c34f8c3418 (patch)
treea476f9b084213e223fde7883a69a92844ea57cae
downloadaur-20a9621657b672ffafd203e90d0308c34f8c3418.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdf29bf91e61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sphvr-git
+ pkgdesc = A GLib library for Vulkan abstraction.
+ pkgver = 0.0.1.63.3a9ec15
+ pkgrel = 1
+ url = https://gitlab.com/lubosz/sphvr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = glslang
+ makedepends = vulkan-headers
+ depends = gulkan-git
+ depends = gst-plugins-bad-libs
+ provides = sphvr=0.0.1.63.3a9ec15
+ conflicts = sphvr
+ source = git+https://gitlab.com/lubosz/sphvr.git
+ md5sums = SKIP
+
+pkgname = sphvr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..562dc06191bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Lubosz Sarnecki <lubosz at gmail com>
+
+_realname='sphvr'
+pkgname="$_realname-git"
+pkgver=0.0.1.63.3a9ec15
+pkgrel=1
+pkgdesc='A GLib library for Vulkan abstraction.'
+arch=('i686' 'x86_64')
+url='https://gitlab.com/lubosz/sphvr'
+depends=('gulkan-git' 'gst-plugins-bad-libs')
+provides=("$_realname="$pkgver)
+conflicts=("$_realname")
+makedepends=('meson' 'git' 'glslang' 'vulkan-headers')
+license=('MIT')
+
+source=('git+https://gitlab.com/lubosz/sphvr.git')
+md5sums=('SKIP')
+
+ver() {
+ PREFIX=" version: '"
+ echo $(grep "$PREFIX" meson.build | sed -e "s/${PREFIX}//" | sed "s/',//")
+}
+
+pkgver() {
+ cd $_realname
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(ver).$revision.$hash
+}
+
+build() {
+ rm -rf build
+ arch-meson $_realname build --libdir=lib --buildtype release -Dapi_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ install -Dm644 "${srcdir}"/sphvr/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}