summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Bagrii2023-07-09 09:31:33 +0300
committerDmytro Bagrii2023-07-09 09:31:33 +0300
commit08b398185b8d8534607d9da52fdd0d00c38632c2 (patch)
treefb49c7e702817e8df44263c97bff87d84fb4df08
downloadaur-08b398185b8d8534607d9da52fdd0d00c38632c2.tar.gz
Initial commit (r45.ff8d3bf)
Signed-off-by: Dmytro Bagrii <dimich.dmb@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d19c57530aba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = spi-ch341-usb-dkms-git
+ pkgdesc = SPI/GPIO driver for CH341
+ pkgver = r45.ff8d3bf
+ pkgrel = 1
+ url = https://github.com/gschorcht/spi-ch341-usb
+ arch = any
+ license = GPL
+ makedepends = git
+ conflicts = spi-ch341-usb-dkms
+ source = git+https://github.com/dimich-dmb/spi-ch341-usb.git
+ sha256sums = SKIP
+
+pkgname = spi-ch341-usb-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2d8f70ff0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dmytro Bagrii <dimich.dmb@gmail.com>
+
+pkgname=spi-ch341-usb-dkms-git
+pkgver=r45.ff8d3bf
+pkgver() {
+ cd "$srcdir/spi-ch341-usb"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgrel=1
+pkgdesc="SPI/GPIO driver for CH341"
+arch=(any)
+url="https://github.com/gschorcht/spi-ch341-usb"
+license=('GPL')
+groups=()
+depends=()
+conflicts=('spi-ch341-usb-dkms')
+makedepends=('git')
+source=('git+https://github.com/dimich-dmb/spi-ch341-usb.git')
+sha256sums=('SKIP')
+
+package() {
+ install -Dm0644 -t "${pkgdir}"/usr/src/spi-ch341-usb-${pkgver} \
+ "${srcdir}"/spi-ch341-usb/Makefile \
+ "${srcdir}"/spi-ch341-usb/spi-ch341-usb.c \
+ "${srcdir}"/spi-ch341-usb/dkms.conf
+ sed -i "s/^PACKAGE_VERSION=.*\$/PACKAGE_VERSION=\"${pkgver}\"/" "${pkgdir}"/usr/src/spi-ch341-usb-${pkgver}/dkms.conf
+
+ install -Dm644 -t "${pkgdir}"/usr/lib/udev/rules.d "${srcdir}"/spi-ch341-usb/udev/99-spi-ch341-usb.rules
+}