summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2020-04-20 19:35:36 +0900
committerShohei Maruyama2020-04-21 22:07:41 +0900
commit6739f4332b5bdf76cc7f838315e6b87c20a7c694 (patch)
treeb179ad04d1804de5e10d4ba5711311f37bada785
downloadaur-6739f4332b5bdf76cc7f838315e6b87c20a7c694.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD38
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8971cefbb2c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = spice-streaming-agent-git
+ pkgdesc = Guest agent to stream video from guest cards
+ pkgver = v0.3.r40.gadcbc83
+ pkgrel = 1
+ url = https://spice-space.org
+ arch = x86_64
+ license = APACHE
+ makedepends = spice-protocol
+ makedepends = meson
+ makedepends = pixman
+ makedepends = gstreamer
+ makedepends = gst-plugins-base
+ makedepends = xorg-xrandr
+ depends = pixman
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = xorg-xrandr
+ source = git+https://gitlab.freedesktop.org/spice/spice-streaming-agent.git
+ source = git+https://gitlab.freedesktop.org/spice/spice-common.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = spice-streaming-agent-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c77b9c5c926d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Shohei Maruyama <cheat.sc.linux@outlook.com>
+
+pkgname=spice-streaming-agent-git
+pkgver=v0.3.r40.gadcbc83
+pkgrel=1
+pkgdesc="Guest agent to stream video from guest cards"
+arch=("x86_64")
+license=("APACHE")
+depends=(pixman gstreamer gst-plugins-base xorg-xrandr)
+makedepends=(spice-protocol meson pixman gstreamer gst-plugins-base xorg-xrandr)
+url="https://spice-space.org"
+source=(
+ "git+https://gitlab.freedesktop.org/spice/spice-streaming-agent.git"
+ "git+https://gitlab.freedesktop.org/spice/spice-common.git"
+)
+sha512sums=(
+ "SKIP"
+ "SKIP"
+)
+
+pkgver() {
+ cd "spice-streaming-agent"
+ git describe --long | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd "spice-streaming-agent"
+ git config submodule.spice-common.url "${srcdir}/spice-common"
+}
+
+build() {
+ meson --prefix /usr --buildtype=plain spice-streaming-agent build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}