summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-06-04 09:40:21 -0700
committermutantmonkey2013-06-04 09:40:21 -0700
commit88e3601169c491e44bda79a8d581fb4cdf94ff8a (patch)
tree3c471f745981cacf0b8db4574885999a464ff376
parent6ab8eb75b2e865a27c5317e4552b0424278da822 (diff)
downloadaur-88e3601169c491e44bda79a8d581fb4cdf94ff8a.tar.gz
update trousers and spice-vdagent to use /usr/bin
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fe374ec1a4e..621a1ce5fb88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.in>
pkgname=spice-vdagent
pkgver=0.14.0
-pkgrel=1
+pkgrel=2
pkgdesc="Spice agent xorg client that enables copy and paste between client and X-session and more"
arch=('i686' 'x86_64')
url="http://www.spice-space.org/"
@@ -16,7 +16,8 @@ sha256sums=('bbaf007615002e4636c5faa6fe6912527f2cfb518aecc9e1f903bc8b0f00767c'
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --with-session-info=none --with-init-script=systemd --enable-static-uinput
+ --sbindir=/usr/bin --with-session-info=none --with-init-script=systemd \
+ --enable-static-uinput
make
}
@@ -29,6 +30,9 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ sed -i 's/\/etc\/sysconfig\/spice-vdagentd/\/etc\/conf.d\/spice-vdagentd.conf/' $pkgdir/usr/lib/systemd/system/spice-vdagentd.service
+ sed -i 's/\/usr\/sbin/\/usr\/bin/' $pkgdir/usr/lib/systemd/system/spice-vdagentd.service
+
install -Dm0755 "${srcdir}/spice-vdagentd.conf.d" "${pkgdir}/etc/conf.d/spice-vdagentd.conf"
}