summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-03-03 20:23:51 +0100
committerPeter Mattern2016-03-03 20:23:51 +0100
commit05684b63cb6e41dd8ebb2d188c336059044a7a87 (patch)
treecd783a9dfb525da00c070b6950c0616db2d82148
downloadaur-05684b63cb6e41dd8ebb2d188c336059044a7a87.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD64
-rw-r--r--spice-vdagentd.conf.sample13
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dcae74d6d96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Mar 3 18:41:18 UTC 2016
+pkgbase = spice-vdagent-git
+ pkgdesc = SPICE VDAgent for Linux
+ pkgver = 0.16.0.9.geb01d32
+ pkgrel = 1
+ url = http://www.spice-space.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = spice-protocol>=0.12.8
+ depends = glib2
+ depends = alsa-lib
+ depends = libpciaccess
+ depends = libxfixes
+ depends = libxrandr
+ depends = libxinerama
+ provides = spice-vdagent
+ conflicts = spice-vdagent
+ source = spice-vdagent::git://anongit.freedesktop.org/spice/linux/vd_agent
+ source = spice-vdagentd.conf.sample
+ sha256sums = SKIP
+ sha256sums = ab5231eb6375fee5baaf10a59559e7dea58def158fa0ab8e125e9b7340c5e4e8
+
+pkgname = spice-vdagent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..608eeee32dfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=spice-vdagent
+pkgname=$_pkgname-git
+pkgver=0.16.0.9.geb01d32
+pkgrel=1
+pkgdesc='SPICE VDAgent for Linux'
+arch=('i686' 'x86_64')
+url='http://www.spice-space.org'
+license=('GPL')
+depends=('glib2' 'alsa-lib' 'libpciaccess' 'libxfixes' 'libxrandr' 'libxinerama')
+makedepends=('git' 'spice-protocol>=0.12.8')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git://anongit.freedesktop.org/spice/linux/vd_agent"
+ spice-vdagentd.conf.sample)
+sha256sums=("SKIP"
+ ab5231eb6375fee5baaf10a59559e7dea58def158fa0ab8e125e9b7340c5e4e8)
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed 's:^spice-vdagent.::;s:-:.:g'
+}
+
+prepare() {
+
+ # adjustment of several paths to the habits of Arch Linux
+
+ cd $_pkgname
+
+ # don't expect file providing command line options for spice-vdagentd in /etc/sysconfig
+ sed -i 's:etc/sysconfig.*$:etc/spice/spice-vdagentd.conf:' data/spice-vdagentd.service
+
+ # /bin and /usr/sbin should be avoided
+ sed -i 's:bin.rm:usr/bin/rm:;s:sbin:bin:' data/spice-vdagentd.service
+
+ # place runtime data directory in /run instead of /var/run
+ sed -i 's:$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd:true:' Makefile.am
+ sed -i 's:/var::' data/tmpfiles.d/spice-vdagentd.conf
+
+ # place udev rules file in /usr/lib instead of /lib
+ sed -i 's:udevrulesdir = /lib:udevrulesdir = /usr/lib:' Makefile.am
+
+}
+
+build() {
+ cd $_pkgname
+ autoreconf -fi
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --localstatedir=/var \
+ --with-init-script=systemd
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR=$pkgdir install
+
+ # sample configuration file to pass command line options to spice-vdagentd
+ install -Dm644 -t $pkgdir/usr/share/doc/spice-vdagent/ $srcdir/spice-vdagentd.conf.sample
+}
diff --git a/spice-vdagentd.conf.sample b/spice-vdagentd.conf.sample
new file mode 100644
index 000000000000..463bec9927de
--- /dev/null
+++ b/spice-vdagentd.conf.sample
@@ -0,0 +1,13 @@
+# Sample configuration file to pass arbitrary command line options to spice-vdagentd
+#
+# This file is optionally sourced by directive EnvironmentFile of systemd unit
+# spice-vdagentd.service which passes the value of environment variable
+# $SPICE_VDAGENTD_EXTRA_ARGS as command line options to binary spice-vdagentd.
+#
+# It's basically file /etc/sysconfig/spice-vdagentd proposed by upstream, see man (1)
+# spice-vdagentd, with some modified path.
+#
+# To make use of it, copy the file to /etc/spice/spice-vdagentd.conf, uncomment
+# the variable below and adjust the options to your needs.
+
+# SPICE_VDAGENTD_EXTRA_ARGS="-d -u /dev/alternate/path"