summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordbarbosa02022-07-17 09:24:48 -0300
committerdbarbosa02022-07-17 09:24:48 -0300
commit206867f55f21edb2243a5ccda266d26036e9678b (patch)
tree8f933bf9e392fe7f30144341f14080f6e63d98d5
downloadaur-206867f55f21edb2243a5ccda266d26036e9678b.tar.gz
First commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD48
-rw-r--r--spice_opus.pngbin0 -> 9178 bytes
-rw-r--r--spiceopus-cir.xml7
-rw-r--r--spiceopus.desktop9
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..496fb6b8c6dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = spiceopus
+ pkgdesc = Spice Opus is a free general purpose circuit simulator specially suited for optimization loops
+ pkgver = 2v33r242
+ pkgrel = 1
+ url = http://www.spiceopus.si/
+ arch = x86_64
+ license = GPL3
+ source = http://www.spiceopus.si/download/spice_opus233r242_linux_amd64.tar.gz
+ sha256sums = 52d70f8f6878d6ce0d0e33cdb09a2501edbd5081e6739e2fc1c1246424578929
+
+pkgname = spiceopus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de94967ecafd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Daniel Barbosa <dbarbosa0 at gmail dot com>
+
+pkgname=spiceopus
+pkgver=2v33r242
+pkgrel=1
+pkgdesc="Spice Opus is a free general purpose circuit simulator specially suited for optimization loops"
+arch=('x86_64')
+url="http://www.spiceopus.si/"
+license=(GPL3)
+depends=()
+conflicts=()
+source=(http://www.spiceopus.si/download/spice_opus233r242_linux_amd64.tar.gz)
+sha256sums=('52d70f8f6878d6ce0d0e33cdb09a2501edbd5081e6739e2fc1c1246424578929')
+
+OPUSHOME=/opt/$pkgname
+
+package() {
+
+ cd "$srcdir"/spice_opus233r242_linux_amd64_15.Apr.2021_09.29
+ install -d "$pkgdir"$OPUSHOME
+ cp -R * "$pkgdir"$OPUSHOME
+ install -d "$pkgdir"/usr/local/bin/
+ ln -s $OPUSHOME/bin/spiceopus.bin "$pkgdir"/usr/local/bin/spiceopus
+ install -d "$pkgdir"/etc/profile.d/
+echo "export OPUSHOME=$OPUSHOME
+export SPICE_LIB_DIR=$OPUSHOME/lib/spiceopus
+export SPICE_EXEC_DIR=$OPUSHOME/bin" > "$pkgdir"/etc/profile.d/$pkgname.sh
+
+ install -Dm644 "${startdir}/spiceopus.desktop" "${pkgdir}/usr/share/applications/spiceopus.desktop"
+ install -Dm644 "${startdir}/spice_opus.png" "${pkgdir}/usr/share/pixmaps/spiceopus.png"
+ install -Dm644 "${startdir}/spiceopus-cir.xml" "${pkgdir}/usr/share/mime/packages/spiceopus-cir.xml"
+
+}
+
+pre_remove(){
+ rm /etc/profile.d/$pkgname.sh
+ rm /usr/local/bin/$pkgname
+}
+
+post_install(){
+ sudo xdg-mime install /usr/share/mime/packages/spiceopus-cir.xml
+ sudo update-mime-database /usr/share/mime
+ sudo xdg-mime default spiceopus.desktop application/spiceopus
+}
+
+post_remove(){
+ sudo xdg-mime uninstall /usr/share/mime/packages/spiceopus-cir.xml
+}
diff --git a/spice_opus.png b/spice_opus.png
new file mode 100644
index 000000000000..96e504ff0b2a
--- /dev/null
+++ b/spice_opus.png
Binary files differ
diff --git a/spiceopus-cir.xml b/spiceopus-cir.xml
new file mode 100644
index 000000000000..ab381436f51c
--- /dev/null
+++ b/spiceopus-cir.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+ <mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/spiceopus">
+ <comment>Spice Opus File</comment>
+ <glob pattern="*.cir"/>
+ </mime-type>
+ </mime-info>
diff --git a/spiceopus.desktop b/spiceopus.desktop
new file mode 100644
index 000000000000..a9c34f0b6d55
--- /dev/null
+++ b/spiceopus.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=spiceopus
+Comment=A free general purpose circuit simulator specially suited for optimization loops
+Terminal=false
+Name=Spice Opus
+Icon=/usr/share/pixmaps/spiceopus.png
+Categories=Science;Education;