summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2023-02-10 19:03:21 +0100
committerFrancesco Minnocci2023-02-10 19:03:21 +0100
commit2176e9afbaca74f4357b066e112ae02851143d3d (patch)
tree1ee19b26e95431cf2d65f130a5366306c2a1e45f
parent34b5525b610d1d68eb0e2d98fdb083e7f78d3ac9 (diff)
downloadaur-2176e9afbaca74f4357b066e112ae02851143d3d.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0275cf6099e1..4dfca0f68f3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = spicetify-cli-git
pkgdesc = Command-line tool to customize Spotify client - Git master branch
- pkgver = 2.6.1.r2.gc84c381
- pkgrel = 2
- url = https://github.com/khanhas/spicetify-cli
+ pkgver = 2.16.1.r1.gd5cc68f
+ pkgrel = 1
+ url = https://github.com/spicetify/spicetify-cli
arch = x86_64
arch = i686
- license = GPL
+ license = LGPL2.1
makedepends = git
makedepends = go
provides = spicetify-cli
conflicts = spicetify-cli
- source = git+https://github.com/khanhas/spicetify-cli.git
+ source = git+https://github.com/spicetify/spicetify-cli.git
sha256sums = SKIP
pkgname = spicetify-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 70f0843b78b8..c0aee3ecbfab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
_gitname=spicetify-cli
pkgname="${_gitname}-git"
-pkgver=2.6.1.r2.gc84c381
-pkgrel=2
+pkgver=2.16.1.r1.gd5cc68f
+pkgrel=1
pkgdesc='Command-line tool to customize Spotify client - Git master branch'
arch=('x86_64' 'i686')
-url="https://github.com/khanhas/${_gitname}"
-license=('GPL')
+url="https://github.com/spicetify/${_gitname}"
+license=('LGPL2.1')
makedepends=('git' 'go')
source=("git+${url}.git")
sha256sums=('SKIP')
@@ -20,17 +20,21 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd "$srcdir/${_gitname}"
- export GOPATH="$srcdir"
- go build -o spicetify
+ echo "#!/bin/sh
+/usr/share/${_gitname}/spicetify \"\$@\"" > ./shortcut
}
-check() {
+build() {
cd "$srcdir/${_gitname}"
- ./spicetify -v
+ export GOPATH="$srcdir"
+ go build -o spicetify
+
+ # Clean up deps
+ go clean -modcache
}
package() {
@@ -39,12 +43,6 @@ package() {
install -Dm755 ./spicetify "$pkgdir"/usr/share/${_gitname}/spicetify
cp -r ./Themes ./css-map.json ./Extensions ./CustomApps ./jsHelper ./globals.d.ts -t "$pkgdir"/usr/share/${_gitname}
- rm -f ./shortcut
- echo "#!/bin/sh
-/usr/share/${_gitname}/spicetify \"\$@\"" >> ./shortcut
install -Dm755 ./shortcut "$pkgdir"/usr/bin/spicetify
-
- # Clean up deps
- go clean -modcache
}
# vim:set ts=2 sw=2 et: