summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-05-10 13:27:06 +0200
committerFrancesco Minnocci2021-05-10 13:27:06 +0200
commit6dc50f0f34d6a4e47a874e9d5b6b863a44901a0b (patch)
tree9e3f9725ba4dec1940c4dbda8238f2b10e02205b
parentd3421a8dbb54bc421dc1e9a65091e8572f896bd0 (diff)
downloadaur-6dc50f0f34d6a4e47a874e9d5b6b863a44901a0b.tar.gz
Fix pkgver()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 102d74d90029..53de0f4e67c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spicetify-cli-git
pkgdesc = Command-line tool to customize Spotify client - Git master branch
- pkgver = v1.2.0
- pkgrel = 1
+ pkgver = 1.2.1.r21.ge6a9ab9
+ pkgrel = 2
url = https://github.com/khanhas/spicetify-cli
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index cde47e6b26e7..0b8b83e6c196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_gitname=spicetify-cli
pkgname="${_gitname}-git"
-pkgver=v1.2.0
-pkgrel=1
+pkgver=1.2.1.r21.ge6a9ab9
+pkgrel=2
pkgdesc='Command-line tool to customize Spotify client - Git master branch'
arch=('x86_64' 'i686')
url="https://github.com/khanhas/${_gitname}"
@@ -17,7 +17,7 @@ conflicts=("${_gitname}")
pkgver() {
cd "$srcdir/${_gitname}"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -25,6 +25,7 @@ build() {
export GOPATH="$srcdir"
go build -o spicetify
+ go clean -modcache
}
check() {