summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorpheusthewhite2019-09-04 15:03:05 +0200
committermorpheusthewhite2019-09-04 15:03:05 +0200
commit385d0c68d55d369d4d58150e01517c465eeebca5 (patch)
tree0c5c588a79c837cb361e30196044a7a8cfd31d7d
downloadaur-385d0c68d55d369d4d58150e01517c465eeebca5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae5fdaa6b2c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spicetify-themes-git
+ pkgdesc = A community-driven collection of themes for spicetify
+ pkgver = r13.5f997e3
+ pkgrel = 1
+ url = https://github.com/morpheusthewhite/spicetify-themes
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = spicetify-cli
+ provides = spicetify-themes
+ conflicts = spicetify-themes
+ source = ${pkgname}-${pkgver}.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz
+ md5sums = SKIP
+
+pkgname = spicetify-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d68efa8dc6a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: morpheusthewhite <zffromGerace@hotmail.it>
+
+pkgname=spicetify-themes-git
+pkgver=r13.5f997e3
+pkgrel=1
+pkgdesc="A community-driven collection of themes for spicetify"
+arch=('any')
+url="https://github.com/morpheusthewhite/spicetify-themes"
+license=('MIT')
+groups=()
+depends=('spicetify-cli')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=''
+source=('${pkgname}-${pkgver}.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/spicetify-cli
+
+ cp -R "$srcdir/${pkgname%-git}-master" "${pkgdir}"/usr/share/spicetify-cli/Themes
+ rm -r "${pkgdir}"/usr/share/spicetify-cli/Themes/README.md "${pkgdir}"/usr/share/spicetify-cli/Themes/LICENSE
+}