summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorpheusthewhite2020-08-18 08:31:18 +0200
committermorpheusthewhite2020-08-18 08:31:18 +0200
commit540e91cdb57ab94af59a8b25e5c4a82a33cd6e57 (patch)
tree440d76c110babc8466f4939ce2cdc2d18f293913
parent658997f20898cfab3f331612ceb8a033f7673b43 (diff)
downloadaur-540e91cdb57ab94af59a8b25e5c4a82a33cd6e57.tar.gz
Replace wget with git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fb1f646d603..548b9535d3f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spicetify-themes-git
pkgdesc = A community-driven collection of themes for spicetify
- pkgver = r5.7b1ab7a
+ pkgver = r7.658997f
pkgrel = 1
url = https://github.com/morpheusthewhite/spicetify-themes
install = spicetify-themes-git.install
@@ -10,7 +10,7 @@ pkgbase = spicetify-themes-git
depends = spicetify-cli
provides = spicetify-themes
conflicts = spicetify-themes
- source = spicetify-themes-git-r5.7b1ab7a.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz
+ source = spicetify-themes-git::git+https://github.com/morpheusthewhite/spicetify-themes
md5sums = SKIP
pkgname = spicetify-themes-git
diff --git a/PKGBUILD b/PKGBUILD
index f4b849f30462..1db79427045e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: morpheusthewhite <zffromGerace@hotmail.it>
pkgname=spicetify-themes-git
-pkgver=r5.7b1ab7a
+pkgver=r7.658997f
pkgrel=1
pkgdesc="A community-driven collection of themes for spicetify"
arch=('any')
@@ -16,22 +16,21 @@ replaces=()
backup=()
options=()
install=spicetify-themes-git.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz")
+source=("$pkgname"::"git+https://github.com/morpheusthewhite/spicetify-themes")
noextract=()
md5sums=('SKIP')
pkgver() {
- cd "$srcdir"
+ cd "$srcdir"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- mkdir -p "${pkgdir}"/usr/share/spicetify-cli/Extensions
+ mkdir -p "${pkgdir}"/usr/share/spicetify-cli/Extensions
- cp -R "$srcdir/${pkgname%-git}-master" "${pkgdir}"/usr/share/spicetify-cli/Themes
- rm -r "${pkgdir}"/usr/share/spicetify-cli/Themes/README.md "${pkgdir}"/usr/share/spicetify-cli/Themes/LICENSE
+ cp -R "$srcdir/${pkgname}" "${pkgdir}"/usr/share/spicetify-cli/Themes
+ rm -r "${pkgdir}"/usr/share/spicetify-cli/Themes/README.md "${pkgdir}"/usr/share/spicetify-cli/Themes/LICENSE
# for Dribbblish theme
- cp -R "$srcdir/${pkgname%-git}-master/Dribbblish/dribbblish.js" "${pkgdir}"/usr/share/spicetify-cli/Extensions/dribbblish.js
+ cp -R "$srcdir/${pkgname}/Dribbblish/dribbblish.js" "${pkgdir}"/usr/share/spicetify-cli/Extensions/dribbblish.js
}
-