summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorpheusthewhite2020-06-04 08:58:56 +0200
committermorpheusthewhite2020-06-04 08:58:56 +0200
commit7b1ab7a6df5aa2b9356a755a5d2bbb9c4698286c (patch)
tree644bb5170cc00a0a02d95dcb420254ec8a7b8ef2
parentae45f4d98cccc81852820f639cea3eac19f6a403 (diff)
downloadaur-7b1ab7a6df5aa2b9356a755a5d2bbb9c4698286c.tar.gz
Add Dribblish extension installation and post install hook
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--spicetify-themes-git.install12
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8b9e595e09a..59bd1a6a0e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = spicetify-themes-git
pkgdesc = A community-driven collection of themes for spicetify
- pkgver = r1.385d0c6
+ pkgver = r4.ae45f4d
pkgrel = 1
url = https://github.com/morpheusthewhite/spicetify-themes
+ install = spicetify-themes-git.install
arch = any
license = MIT
makedepends = git
depends = spicetify-cli
provides = spicetify-themes
conflicts = spicetify-themes
- source = spicetify-themes-git-r1.385d0c6.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz
+ source = spicetify-themes-git-r4.ae45f4d.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz
md5sums = SKIP
pkgname = spicetify-themes-git
diff --git a/PKGBUILD b/PKGBUILD
index fda913ce9e19..aafd3f16c6f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: morpheusthewhite <zffromGerace@hotmail.it>
pkgname=spicetify-themes-git
-pkgver=r1.385d0c6
+pkgver=r4.ae45f4d
pkgrel=1
pkgdesc="A community-driven collection of themes for spicetify"
arch=('any')
@@ -15,7 +15,7 @@ conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=()
-install=''
+install=spicetify-themes-git.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/morpheusthewhite/spicetify-themes/archive/master.tar.gz")
noextract=()
md5sums=('SKIP')
@@ -26,8 +26,12 @@ pkgver() {
}
package() {
- mkdir -p "${pkgdir}"/usr/share/spicetify-cli
+ mkdir -p "${pkgdir}"/usr/share/spicetify-cli/Extensions
cp -R "$srcdir/${pkgname%-git}-master" "${pkgdir}"/usr/share/spicetify-cli/Themes
rm -r "${pkgdir}"/usr/share/spicetify-cli/Themes/README.md "${pkgdir}"/usr/share/spicetify-cli/Themes/LICENSE
+
+ # for Dribbblish theme
+ cp -R "$srcdir/${pkgname%-git}-master/Dribbblish/dribbblish.js" "${pkgdir}"/usr/share/spicetify-cli/Extensions/dribbblish.js
}
+
diff --git a/spicetify-themes-git.install b/spicetify-themes-git.install
new file mode 100644
index 000000000000..fdfca692dc8a
--- /dev/null
+++ b/spicetify-themes-git.install
@@ -0,0 +1,12 @@
+post_install(){
+ # generate config file
+ spicetify
+
+ spicetify backup apply enable-devtool
+
+ ## Dribbblish theme installation
+ #spicetify config extensions dribbblish.js
+ #spicetify config current_theme Dribbblish color_scheme base
+ #spicetify config inject_css 1 replace_colors 1 overwrite_assets 1
+}
+