aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2019-03-29 12:32:26 +0100
committerGordian Edenhofer2019-03-29 12:32:26 +0100
commit6fbdab7b35b0b5bc067e0793c044fc70127ccf30 (patch)
treedd2bf25052b46b1a53143f96580e5fcd61c4324c
parent057dca49e3c96043a16c8580dbfa1e9fbe3aab1a (diff)
downloadaur-6fbdab7b35b0b5bc067e0793c044fc70127ccf30.tar.gz
upgpkg: minecraft-server 1.13.2-4
Fix search-and-replace mistakes made in commit b382febaf5. upgpkg: cuberite 1.12b1014-2 upgpkg: spigot 1.13.2+b93-2
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xspigot.sh4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aab5235af2c7..891e37b4fb67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spigot
pkgdesc = High performance Minecraft server implementation
pkgver = 1.13.2+b93
- pkgrel = 1
+ pkgrel = 2
url = https://www.spigotmc.org/
install = spigot.install
arch = any
@@ -35,6 +35,6 @@ pkgbase = spigot
sha512sums = 76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c
sha512sums = 5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee
sha512sums = 33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b
- sha512sums = 58c48e7f06bc4508ca4ef2f661efcec3ab7aea56fd6cc46e1a9a33a99ea978e39912105b74fd359160b25a65195cd4812d8055501d97fc8a8f80ce388ee21a98
+ sha512sums = 71a0b73374d153eee49925f0c1487ab95eb9b39b5c7dd3dea356c21345162abdeb7ba796a777c5c4171f6f2b4f69b8eeb8a4001a9628f24f191594386b8e148b
pkgname = spigot
diff --git a/PKGBUILD b/PKGBUILD
index 7f62f241c421..c65116935a26 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=spigot
_pkgver=1.13.2
_build=93
pkgver="${_pkgver}+b${_build}"
-pkgrel=1
+pkgrel=2
pkgdesc="High performance Minecraft server implementation"
arch=('any')
url="https://www.spigotmc.org/"
@@ -29,7 +29,7 @@ sha512sums=('f559fa53c0465d30a0165b643e01a7ddb576282c42d18b899bf844651c4fa144a5e
'76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c'
'5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee'
'33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b'
- '58c48e7f06bc4508ca4ef2f661efcec3ab7aea56fd6cc46e1a9a33a99ea978e39912105b74fd359160b25a65195cd4812d8055501d97fc8a8f80ce388ee21a98')
+ '71a0b73374d153eee49925f0c1487ab95eb9b39b5c7dd3dea356c21345162abdeb7ba796a777c5c4171f6f2b4f69b8eeb8a4001a9628f24f191594386b8e148b')
_game="spigot"
_server_root="/srv/craftbukkit"
diff --git a/spigot.sh b/spigot.sh
index 7cb351d97b25..c5d396ad598a 100755
--- a/spigot.sh
+++ b/spigot.sh
@@ -295,7 +295,7 @@ server_restart() {
# Backup the directories specified in BACKUP_PATHS
backup_files() {
# Check for the availability of the tar binaries
- if command -v tar &> /dev/null; then
+ if ! command -v tar &> /dev/null; then
>&2 echo "The tar binaries are needed for a backup."
exit 11
fi
@@ -329,7 +329,7 @@ backup_files() {
# Restore backup
backup_restore() {
# Check for the availability of the tar binaries
- if command -v tar &> /dev/null; then
+ if ! command -v tar &> /dev/null; then
>&2 echo "The tar binaries are needed for a backup."
exit 11
fi