aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-09-21 12:18:48 +0900
committerGordian Edenhofer2018-09-21 12:18:48 +0900
commit92136644b701deb7c138a439703eacaf6595a177 (patch)
treeeaef39438068fd4b053d4c2f8cdebb8b51c17789
parente1cac33e8970ace5568ae1cc1a56eee17cfd44d4 (diff)
downloadaur-92136644b701deb7c138a439703eacaf6595a177.tar.gz
upgpkg: minecraft-server 1.13.1-1
Broaden the scope of the regex which searches for active users in the minecraftd.sh management script to include more escape sequences. This notably enables using the idle_server part of the script in combination with the 'Paper' minecraft server. upgpkg: cuberite 1.12b975-2 upgpkg: spigot 1.12.2+b73-2
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xspigot.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c7ca77210c..01d2e5cecf96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,6 +35,6 @@ pkgbase = spigot
sha512sums = 76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c
sha512sums = 5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee
sha512sums = 33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b
- sha512sums = f60f79121b9fd2b5bd117b539f5455b348ee9a5b5c16712ad71b362b8efff3e748c00df4d42135cdce9192cb35d0d9588d0fc5d0e28e6d493df076257586d164
+ sha512sums = f9dd90e72aa8b5ac3338c9fb267b0826615a7125bd93a42eb13864f828ad45954959e9645863755a88399331685f3bf00d9fc0f096c8dac1f8f8607c93189c1f
pkgname = spigot
diff --git a/PKGBUILD b/PKGBUILD
index 3e586ff1c836..cf56877c64f8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ sha512sums=('b9dfe324f7eed186278285595e6785cdeb197cec2cac59442b79731ac70ebee2247
'76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c'
'5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee'
'33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b'
- 'f60f79121b9fd2b5bd117b539f5455b348ee9a5b5c16712ad71b362b8efff3e748c00df4d42135cdce9192cb35d0d9588d0fc5d0e28e6d493df076257586d164')
+ 'f9dd90e72aa8b5ac3338c9fb267b0826615a7125bd93a42eb13864f828ad45954959e9645863755a88399331685f3bf00d9fc0f096c8dac1f8f8607c93189c1f')
_game="spigot"
_server_root="/srv/craftbukkit"
diff --git a/spigot.sh b/spigot.sh
index 5af172b46d84..a110285322e9 100755
--- a/spigot.sh
+++ b/spigot.sh
@@ -86,10 +86,10 @@ is_player_online() {
# and since playernames may not contain this string the clean player-list can easily be retrieved.
# Otherwiese check the first digit after the last occurrence of "There are". If it is 0 then there
# are no players on the server. Should this test fail as well. Assume that a player is online.
- if [[ $(echo "${response}" | grep ":" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})?)?[m|K]//g' -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
+ if [[ $(echo "${response}" | grep ":" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g' -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
# No player is online
return 0
- elif [[ $(echo "${response}" | grep "There are" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})?)?[m|K]//g' -e 's/.*\: //' -e 's/^([^.]+).*$/\1/; s/^[^0-9]*([0-9]+).*$/\1/' | tr -d '\n') -eq 0 ]]; then
+ elif [[ $(echo "${response}" | grep "There are" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g' -e 's/.*\: //' -e 's/^([^.]+).*$/\1/; s/^[^0-9]*([0-9]+).*$/\1/' | tr -d '\n') -eq 0 ]]; then
# No player is online
return 0
else