aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2019-09-25 09:55:27 +0200
committerGordian Edenhofer2019-09-25 10:00:14 +0200
commitca7a6ca2e4e0cbeda89236a0ec5f57a5ee565ea4 (patch)
tree1d5d1f1ad35ea4e2ffa099fb8bd93581bd31ebad
parent68abc622aff5a7e76e78eccb5ff392bfbbac3994 (diff)
downloadaur-ca7a6ca2e4e0cbeda89236a0ec5f57a5ee565ea4.tar.gz
upgpkg: minecraft-server 1.14.4-2
Fix a bug which was most likely introduced in ada9f5931d preventing the `is_player_online` function to parse the response properly for some servers and in particular papermc. The bug deleted lines which were not intended to be deleted. As a fix, just stop deleting any lines as all subsequent invocations use grep anyway and hence already select the right line. upgpkg: cuberite 1.12b1049-1 upgpkg: papermc 1.14.4+b196-1 upgpkg: spigot 1.14.4+b103-2
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xspigot.sh6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e72b2952324..024779b5cbe0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spigot
pkgdesc = High performance Minecraft server implementation
pkgver = 1.14.4+b103
- pkgrel = 1
+ pkgrel = 2
url = https://www.spigotmc.org/
install = spigot.install
arch = any
@@ -35,6 +35,6 @@ pkgbase = spigot
sha512sums = 76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c
sha512sums = 5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee
sha512sums = 33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b
- sha512sums = 71a0b73374d153eee49925f0c1487ab95eb9b39b5c7dd3dea356c21345162abdeb7ba796a777c5c4171f6f2b4f69b8eeb8a4001a9628f24f191594386b8e148b
+ sha512sums = 28d8292d442b8f77ce2b568f2ac0a10474d12361f02ae4e6e67e810d653f5a7e1e100d1f937dec2dfea35fd736047f55a7fb0d8754628b23d1a81948c0d62009
pkgname = spigot
diff --git a/PKGBUILD b/PKGBUILD
index 43ca808e344a..7456667a1849 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=spigot
_pkgver=1.14.4
_build=103
pkgver="${_pkgver}+b${_build}"
-pkgrel=1
+pkgrel=2
pkgdesc="High performance Minecraft server implementation"
arch=('any')
url="https://www.spigotmc.org/"
@@ -29,7 +29,7 @@ sha512sums=('4a8a65f243f730f2ac7400e237710e6f511fc3e53937174b3e66a0b8e136f8076f7
'76c77e47c442b477216e968db2213612579b24add54cf0e0512f808498673500b4d24e59bce70b1e7479d724a9a897ceb154e937b88a476beb11c8776258b36c'
'5a32439ff4b8fa9db89e9242206cf99109e0b00f29f87711c25342dda522171d999f7e18fb2013437ddf62cfec05b6677601933233aaf42bcb5d67eb7a1469ee'
'33f456fd945bb2cfa6b390ce0ab02753cc6366e39abff80a4f2b7aa3aebe3cd31d148b785cbc2aa159dd8ad9fb03233a09f8693eb031b6b9db8dc03643d2397b'
- '71a0b73374d153eee49925f0c1487ab95eb9b39b5c7dd3dea356c21345162abdeb7ba796a777c5c4171f6f2b4f69b8eeb8a4001a9628f24f191594386b8e148b')
+ '28d8292d442b8f77ce2b568f2ac0a10474d12361f02ae4e6e67e810d653f5a7e1e100d1f937dec2dfea35fd736047f55a7fb0d8754628b23d1a81948c0d62009')
_game="spigot"
_server_root="/srv/craftbukkit"
diff --git a/spigot.sh b/spigot.sh
index c5d396ad598a..f5a656aae1ed 100755
--- a/spigot.sh
+++ b/spigot.sh
@@ -83,10 +83,10 @@ game_command() {
is_player_online() {
response="$(sleep_time=0.6 return_stdout=true game_command list)"
# Delete leading line and free response string from fancy characters
- response="$(echo "${response}" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g')"
+ response="$(echo "${response}" | sed -r -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g')"
# The list command prints a line containing the usernames after the last occurrence of ": "
# and since playernames may not contain this string the clean player-list can easily be retrieved.
- # Otherwiese check the first digit after the last occurrence of "There are". If it is 0 then there
+ # Otherwise check the first digit after the last occurrence of "There are". If it is 0 then there
# are no players on the server. Should this test fail as well. Assume that a player is online.
if [[ $(echo "${response}" | grep ":" | sed -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
# No player is online
@@ -473,7 +473,7 @@ case "${1:-}" in
;;
idle_server_daemon)
- # This shell be a hidden function which should only be invoced internally
+ # This shall be a hidden function which should only be invoced internally
idle_server_daemon
;;