summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-12-12 22:18:49 +0800
committerYen Chi Hsuan2015-12-12 22:18:49 +0800
commitdd04042ece76e6da8b196b56f0df71104206ac61 (patch)
tree8dbbb41abab551772d17d5f6911bc0367c110826
parentc491cecd020648d23c123f48d773b7646ee97ad1 (diff)
downloadaur-dd04042ece76e6da8b196b56f0df71104206ac61.tar.gz
Fix for building against flex 2.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--flex-version-check.patch15
3 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c679319ccc38..70cf09d6d25f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Dec 12 14:18:45 UTC 2015
pkgbase = spim-svn
pkgdesc = A MIPS32 simulator (SVN version)
- pkgver = 674
- pkgrel = 1
+ pkgver = 675
+ pkgrel = 2
url = http://sourceforge.net/projects/spimsimulator/
arch = i686
arch = x86_64
@@ -13,8 +15,10 @@ pkgbase = spim-svn
conflicts = spim
source = svn+http://svn.code.sf.net/p/spimsimulator/code/spim
source = svn+http://svn.code.sf.net/p/spimsimulator/code/CPU
+ source = flex-version-check.patch
md5sums = SKIP
md5sums = SKIP
+ md5sums = 27ccf0eab447f5d4343898b6f9293e8a
pkgname = spim-svn
diff --git a/PKGBUILD b/PKGBUILD
index 07cc374808f3..dc78bf538b17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=spim-svn
-pkgver=674
-pkgrel=1
+pkgver=675
+pkgrel=2
pkgdesc="A MIPS32 simulator (SVN version)"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/spimsimulator/"
@@ -13,8 +13,10 @@ provides=('spim')
_svntrunk='svn+http://svn.code.sf.net/p/spimsimulator/code'
source=("${_svntrunk}/spim"
- "${_svntrunk}/CPU")
-md5sums=("SKIP" "SKIP")
+ "${_svntrunk}/CPU"
+ 'flex-version-check.patch')
+md5sums=("SKIP" "SKIP"
+ '27ccf0eab447f5d4343898b6f9293e8a')
pkgver() {
cd "${srcdir}/spim"
@@ -22,6 +24,12 @@ pkgver() {
printf "${ver//[[:alpha:]]}"
}
+prepare() {
+ cd ${srcdir}/CPU
+
+ patch -p0 -i ../../flex-version-check.patch
+}
+
build() {
cd ${srcdir}/spim
diff --git a/flex-version-check.patch b/flex-version-check.patch
new file mode 100644
index 000000000000..d44c6071ef02
--- /dev/null
+++ b/flex-version-check.patch
@@ -0,0 +1,15 @@
+Index: scanner.l
+===================================================================
+--- scanner.l (revision 675)
++++ scanner.l (working copy)
+@@ -328,7 +328,9 @@
+
+ #ifdef FLEX_SCANNER
+ yyrestart(in_file);
+-#if (YY_FLEX_MAJOR_VERSION==2 && YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33)
++#define YY_FLEX_VERSION \
++ (YY_FLEX_MAJOR_VERSION * 1000 + YY_FLEX_MINOR_VERSION * 100 + YY_FLEX_SUBMINOR_VERSION)
++#if YY_FLEX_VERSION >= 2533
+ /* flex 2.5.33 flipped the polarity of this flag (sigh) */
+ yy_init = 0;
+ #else