summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2016-02-10 18:36:22 +0100
committerfrederik2016-02-10 18:36:22 +0100
commitadb29244ee815907bd0ca1d7e00453ba9daac8bb (patch)
tree30cda38dcf6fb665664439841bb6d54403fa1cee
parent9de6e208391184c0b7582c6d8d5b5d7dd3302293 (diff)
downloadaur-adb29244ee815907bd0ca1d7e00453ba9daac8bb.tar.gz
push version to 6.4.5
add examples to docs
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37c2877236f0..6e909a99caf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 17:35:54 UTC 2016
pkgbase = spin
- pkgdesc = Tool for the formal verification of distributed software systems.
- pkgver = 6.4.4
- pkgrel = 2
+ pkgdesc = Tool for the formal verification of distributed software systems
+ pkgver = 6.4.5
+ pkgrel = 1
url = http://spinroot.com/
arch = i686
arch = x86_64
license = custom:SPIN
depends = glibc
- source = http://spinroot.com/spin/Src/spin644.tar.gz
+ optdepends = tcl: ispin graphical interface
+ optdepends = swarm: improved performance on large verification problems
+ optdepends = modex: extract verification models from implementation C code
+ optdepends = ispin: GUI for Spin
+ source = http://spinroot.com/spin/Src/spin645.tar.gz
source = LICENSE.txt
- sha512sums = cd16613e6bde57dd968a126b9159e28a44ad5698dd20d9b2b542c6be9b79cbfbbc0b6b3c5dfcf3aac11dfa244ad95583fe914899dde3cf685bc6e1fdcd058cea
+ sha512sums = 77bc35bb852c0448915c655bf11910d0b226d30d66abaa63311e6227de03f920ca026e7399cbeebdae631368fd8091f1e8330bd3094bd4febdf7d5c7a81834ad
sha512sums = a5b63fc7136a2631c9a27619953abe2e9d6cab179042dd56bb76afbffe1966ad7edb41a131af5d6663f3cdbf77128833232e9174c0ef817b8522bfd978add595
pkgname = spin
diff --git a/PKGBUILD b/PKGBUILD
index ef0fa3d392a1..820890b68fba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
# Contributor: Ghost of Kendo <ghostofkendo at gmail dot com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
# Contributor: Pierre Chapuis <catwell@archlinux.us>
+# Contributor: Earnest <zibeon@gmail.com>
pkgname=spin
-pkgver=6.4.4
-pkgrel=2
-pkgdesc='Tool for the formal verification of distributed software systems.'
+pkgver=6.4.5
+pkgrel=1
+pkgdesc='Tool for the formal verification of distributed software systems'
arch=('i686' 'x86_64')
url='http://spinroot.com/'
license=('custom:SPIN')
depends=('glibc')
+optdepends=('tcl: ispin graphical interface'
+ 'swarm: improved performance on large verification problems'
+ 'modex: extract verification models from implementation C code'
+ 'ispin: GUI for Spin')
source=("http://spinroot.com/spin/Src/spin${pkgver//./}.tar.gz"
'LICENSE.txt')
-sha512sums=('cd16613e6bde57dd968a126b9159e28a44ad5698dd20d9b2b542c6be9b79cbfbbc0b6b3c5dfcf3aac11dfa244ad95583fe914899dde3cf685bc6e1fdcd058cea'
+sha512sums=('77bc35bb852c0448915c655bf11910d0b226d30d66abaa63311e6227de03f920ca026e7399cbeebdae631368fd8091f1e8330bd3094bd4febdf7d5c7a81834ad'
'a5b63fc7136a2631c9a27619953abe2e9d6cab179042dd56bb76afbffe1966ad7edb41a131af5d6663f3cdbf77128833232e9174c0ef817b8522bfd978add595')
build() {
@@ -28,7 +33,10 @@ package() {
install -D spin ${pkgdir}/usr/bin/spin
install -D -m644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
- # install manpage
- install -d ${pkgdir}/usr/share/man/man1/
+ # install manpage and docs
+ install -d ${pkgdir}/usr/share/man/man1/
+ install -d ${pkgdir}/usr/share/doc/${pkgname}/examples
+
gzip -9c ${srcdir}/Spin/Man/spin.1 > ${pkgdir}/usr/share/man/man1/spin.1.gz
+ cp -a ${srcdir}/Spin/Examples/* ${pkgdir}/usr/share/doc/${pkgname}/examples/
}