summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2019-05-14 18:07:22 +0100
committerAlex Dewar2019-05-14 18:08:17 +0100
commite6f3b58ad668f47cadb75283834caf5581e0f22e (patch)
treeac636e7d474a8d0f29db92547bc5d230689c63f8
downloadaur-e6f3b58ad668f47cadb75283834caf5581e0f22e.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD54
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4c7bc43dad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = spinecreator-git
+ pkgdesc = A user interface for creating neural network simulations
+ pkgver = 0.9.6+git
+ pkgrel = 1
+ url = https://github.com/SpineML/SpineCreator.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = brahms
+ depends = qt5-base
+ provides = spinecreator
+ conflicts = spinecreator
+ source = git+https://github.com/SpineML/SpineML_PreFlight.git
+ source = git+https://github.com/SpineML/SpineML_2_BRAHMS.git
+ source = git+https://github.com/SpineML/SpineCreator.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = spinecreator-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac7daf3bbf97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+/SpineCreator
+/SpineML_2_BRAHMS
+/SpineML_PreFlight
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bc9e57ee647
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
+pkgname=spinecreator-git
+pkgver=0.9.6+gitc045f60
+pkgrel=1
+pkgdesc="A user interface for creating neural network simulations"
+arch=(i686 x86_64)
+url="https://github.com/SpineML/SpineCreator.git"
+license=('GPL3')
+depends=(brahms qt5-base)
+makedepends=(git cmake)
+provides=("spinecreator")
+conflicts=("spinecreator")
+source=("git+https://github.com/SpineML/SpineML_PreFlight.git"
+ "git+https://github.com/SpineML/SpineML_2_BRAHMS.git"
+ "git+https://github.com/SpineML/SpineCreator.git")
+noextract=()
+md5sums=(SKIP SKIP SKIP)
+validpgpkeys=()
+
+pkgver() {
+ echo 0.9.6+git$(git rev-parse --short HEAD)
+}
+
+build() {
+ # Make SpineML_PreFlight
+ cd SpineML_PreFlight
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+ cd ../..
+
+ # Make SpineCreator
+ cd SpineCreator
+ qmake
+ make
+}
+
+package() {
+ # Install SpineML_PreFlight
+ cd SpineML_PreFlight/build
+ make DESTDIR="$pkgdir" install
+ cd ../..
+
+ # Install SpineCreator
+ cd SpineCreator
+ make INSTALL_ROOT="$pkgdir/" install
+ cd ..
+
+ # Install SpineML_2_BRAHMS scripts
+ mkdir -p "$pkgdir/opt/SpineML_2_BRAHMS"
+ cp -R SpineML_2_BRAHMS/* "$pkgdir/opt/SpineML_2_BRAHMS"
+}