summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2015-06-10 14:04:44 +1000
committerSimon Perry (Pezz)2015-06-10 14:04:44 +1000
commit52b610c11b3faf1e1226e81d02c6984c71702973 (patch)
treeee78be89b90399e2f6bc1142608cb3df5890df11
downloadaur-52b610c11b3faf1e1226e81d02c6984c71702973.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..398e8ad3da1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = spiped
+ pkgdesc = Secure pipe daemon
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://www.tarsnap.com/spiped.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = openssl
+ source = http://www.tarsnap.com/spiped/spiped-1.5.0.tgz
+ sha256sums = b2f74b34fb62fd37d6e2bfc969a209c039b88847e853a49e91768dec625facd7
+
+pkgname = spiped
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7db7ba44b1bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Simon Perry <aur [at] sanxion [dot] net>
+# Contributor: Nicolas Pouillard http://nicolaspouillard.fr
+
+pkgname=spiped
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Secure pipe daemon"
+arch=('i686' 'x86_64')
+source=(http://www.tarsnap.com/$pkgname/$pkgname-$pkgver.tgz)
+url="http://www.tarsnap.com/spiped.html"
+license=('BSD')
+depends=('openssl')
+sha256sums=('b2f74b34fb62fd37d6e2bfc969a209c039b88847e853a49e91768dec625facd7')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p ${pkgdir}/usr/share/man/man1
+ MAN1DIR=${pkgdir}/usr/share/man/man1 BINDIR=${pkgdir}/usr/bin make install
+ install -Dm644 COPYRIGHT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+