summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitchell Augustin2021-12-23 21:54:10 -0600
committerMitchell Augustin2021-12-23 21:54:10 -0600
commitc5b9d672375e3315430c522182c7dac367f1772a (patch)
treef0da2b6c1b859606a64a8e7a93d2dddedfad1bd5
downloadaur-c5b9d672375e3315430c522182c7dac367f1772a.tar.gz
Initial commit of Spiral PKGBUILD to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b9adcb0bb36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = spiral-notebook-bin
+ pkgdesc = Free-form notebook software with 'click anywhere to type' functionality, rich-text and image support, and a notebook-based file structure
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://mitchellaugustin.com/spiral/
+ arch = x86_64
+ license = GPL
+ depends = qt5-base>=5.9.0,
+ depends = qt5-declarative>=5.9.0
+ optdepends = qt5-styleplugins
+ source = https://mitchellaugustin.com/spiral/versions/spiral-aur-1.5.tar.gz
+ md5sums = SKIP
+
+pkgname = spiral-notebook-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ed3fc9b4f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mitchell Augustin <mitchell@mitchellaugustin.com>
+pkgname=spiral-notebook-bin
+pkgver=1.5
+pkgrel=1
+epoch=
+pkgdesc="Free-form notebook software with 'click anywhere to type' functionality, rich-text and image support, and a notebook-based file structure"
+arch=('x86_64')
+url="https://mitchellaugustin.com/spiral/"
+license=('GPL')
+groups=()
+depends=('qt5-base>=5.9.0', 'qt5-declarative>=5.9.0')
+makedepends=()
+checkdepends=()
+optdepends=('qt5-styleplugins')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${url}versions/spiral-aur-${pkgver}.tar.gz")
+noextract=()
+md5sums=(SKIP)
+validpgpkeys=()
+
+prepare() {
+ cd "spiral-aur-${pkgver}"
+ ./install.sh
+}
+
+check() {
+ cd "spiral-aur-${pkgver}"
+}
+
+package() {
+ cd "spiral-aur-${pkgver}"
+ install -Dm 755 Spiral.desktop "$pkgdir"/usr/share/applications/Spiral.desktop
+ install -Dm 755 spiral "$pkgdir"/usr/bin/spiral
+ install -Dm 755 spiral.png "$pkgdir"/usr/share/pixmaps/spiral.png
+}