summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-02-29 20:20:57 +0000
committerDaniel Bermond2020-02-29 20:20:57 +0000
commit3a036cf36d3b2e944303d3b37ac68a0964f3b8e7 (patch)
tree3274ceb2abde866d21fb7faab26a9393e9bb2d54
parent26fb6ac510034b98f79f2dacf49086b7e2974c86 (diff)
downloadaur-3a036cf36d3b2e944303d3b37ac68a0964f3b8e7.tar.gz
Updated to version 2020.02.26
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f764b6989e..21ffe0b4d584 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spirv-cross
pkgdesc = A tool and library for parsing and converting SPIR-V to other shader languages
- pkgver = 2020.01.16
+ pkgver = 2020.02.26
pkgrel = 1
url = https://github.com/KhronosGroup/SPIRV-Cross/
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = spirv-cross
makedepends = python
makedepends = python-nose
depends = gcc-libs
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=2020-01-16
- source = git+https://github.com/KhronosGroup/glslang.git#commit=a4af7676feb011d61b1dfa8915bd41d9c5aaf22a
- source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=e82a428605f6ce0a07337b36f8ba3935c9f165ac
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=204cd131c42b90d129073719f2766293ce35c081
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=2020-02-26
+ source = git+https://github.com/KhronosGroup/glslang.git#commit=c008fcb8cc0f6a413162fb5236d0c548cc1e0ef6
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=79f8caf9154a0328a87424354bd10ab69e811185
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=5dbc1c32182e17b8ab8e8158a802ecabaf35aad3
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 44a75b546781..1e70ddf4be30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
-_glslang_commit='a4af7676feb011d61b1dfa8915bd41d9c5aaf22a'
-_spirv_tools_commit='e82a428605f6ce0a07337b36f8ba3935c9f165ac'
-_spirv_headers_commit='204cd131c42b90d129073719f2766293ce35c081'
+_glslang_commit='c008fcb8cc0f6a413162fb5236d0c548cc1e0ef6'
+_spirv_tools_commit='79f8caf9154a0328a87424354bd10ab69e811185'
+_spirv_headers_commit='5dbc1c32182e17b8ab8e8158a802ecabaf35aad3'
pkgname=spirv-cross
-pkgver=2020.01.16
+pkgver=2020.02.26
pkgrel=1
pkgdesc='A tool and library for parsing and converting SPIR-V to other shader languages'
arch=('x86_64')
@@ -33,6 +33,9 @@ prepare() {
build() {
# NOTE: test suite fails when using 'None' build type
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+
# glslang (required for tests)
printf '%s\n' ' -> Building glslang...'
cmake -B SPIRV-Cross/external/glslang-build -S glslang \